aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prometheus-client
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:12 +0100
commitf704c0e068b32606774117847ab73f643f4937af (patch)
treebd60069698667a4adc5171631a4c686937c3206f /community/py3-prometheus-client
parentee4211cacc3103bfb4b9b7498f8b47371defcacb (diff)
downloadaports-f704c0e068b32606774117847ab73f643f4937af.tar.bz2
aports-f704c0e068b32606774117847ab73f643f4937af.tar.xz
community/py3-prometheus-client: move from testing
Diffstat (limited to 'community/py3-prometheus-client')
-rw-r--r--community/py3-prometheus-client/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/py3-prometheus-client/APKBUILD b/community/py3-prometheus-client/APKBUILD
new file mode 100644
index 0000000000..7d442601c4
--- /dev/null
+++ b/community/py3-prometheus-client/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-prometheus-client
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Python3 client for the Prometheus monitoring system"
+url="https://github.com/prometheus/client_python"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-twisted"
+makedepends="python3-dev py3-setuptools"
+options="!check" # Pypi tarballs come without tests
+source="https://pypi.io/packages/source/p/prometheus_client/prometheus_client-$pkgver.tar.gz"
+builddir="$srcdir/prometheus_client-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cd7e7471c7c6d90681ce54ba41bd9fb94f58b799a63f1fca1987f8a59442ee2321d1d7157a0713f29ac32a49f64bae1e8d97ffc8b1e96e304448ae23cb0eb7de prometheus_client-0.7.1.tar.gz"