aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pygal
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-03 23:20:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 16:21:16 -0300
commitf295f477dda6e6943a175db2ba8c80350a5378aa (patch)
treeb0dce0632ab22ed8797bb390fbdbd9e5d0238d1b /community/py3-pygal
parent774ff2e03cc44857c85b06e5527f4d30b80c754a (diff)
downloadaports-f295f477dda6e6943a175db2ba8c80350a5378aa.tar.bz2
aports-f295f477dda6e6943a175db2ba8c80350a5378aa.tar.xz
community/py3-pygal: move from testing
Diffstat (limited to 'community/py3-pygal')
-rw-r--r--community/py3-pygal/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-pygal/APKBUILD b/community/py3-pygal/APKBUILD
new file mode 100644
index 0000000000..c892c726fa
--- /dev/null
+++ b/community/py3-pygal/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-pygal
+_pkgname=pygal
+pkgver=2.4.0
+pkgrel=4
+pkgdesc="A dynamic SVG charting library written in Python"
+options="!check" # Requires unpackaged dependencies
+url="https://pygal.org"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/pygal/pygal-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-pygal" # Backwards compatibility
+provides="py-pygal=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="5cb95ca5c0cf74ae476953f3503154a305a0b5e42c69191b0b46f6e6cfea8c806713fe175329a69b393654d055997b2063cf3b641e91009a2b7bef219bb49ddb pygal-2.4.0.tar.gz"