aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pygit2
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-04-02 21:40:48 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 21:33:22 +0000
commitfff195823fe922023990f86f9ea32f6426eba024 (patch)
tree456b99cb2001a10a1b59c78c260ffab708539ccc /community/py3-pygit2
parent9486f6c34b38a23780520c61c24a0f4bc0bbeb6b (diff)
downloadaports-fff195823fe922023990f86f9ea32f6426eba024.tar.bz2
aports-fff195823fe922023990f86f9ea32f6426eba024.tar.xz
community/py3-pygit2: upgrade to 1.1.1
Diffstat (limited to 'community/py3-pygit2')
-rw-r--r--community/py3-pygit2/APKBUILD10
-rw-r--r--community/py3-pygit2/fix-1.0.patch15
2 files changed, 21 insertions, 4 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 74e9e2b583..c7739af9d1 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pygit2
_pkgname=pygit2
-pkgver=1.0.3
+pkgver=1.1.1
pkgrel=0
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
@@ -11,9 +11,10 @@ arch="all"
license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-six"
makedepends="python3-dev py3-setuptools libgit2-dev"
-checkdepends="py3-pytest py3-hypothesis"
+checkdepends="py3-pytest py3-hypothesis py3-cached-property"
source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
skip-failing-test-on-s390x.patch
+ fix-1.0.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -32,5 +33,6 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="debf4018e6daa938f44cf22f2acec1f850156e30ac44052e2edb8257f86a60453428356851cc495ae234df9cdbee922a6a7ad7886c9a6e3746b7315c71f0a3df pygit2-1.0.3.tar.gz
-1bd1ed146ebfae659c20aa641f795606a32e485fab13a71db12345082a18a9de9f0129d8375ffb6bf8616c906c59d0b25fb440e1f00bcd56e3e10b9aac3363fd skip-failing-test-on-s390x.patch"
+sha512sums="e57600f1eb53647106cdc703d8adcdff7742bde8d3d95d8a879275ec1ac4a4a569d6f7da68a9bf49e82f491980e19abf96e55029f3fbae52371632e6bd3b2ab3 pygit2-1.1.1.tar.gz
+1bd1ed146ebfae659c20aa641f795606a32e485fab13a71db12345082a18a9de9f0129d8375ffb6bf8616c906c59d0b25fb440e1f00bcd56e3e10b9aac3363fd skip-failing-test-on-s390x.patch
+d80c2cabfe2ca074e78f53bc7f87fa3841e7bc0bc57e181e1cf72e6e728c529b5246d9cb8a15949abaa55b6c59a95ecd1c939e62121d61b3d542263793edc15d fix-1.0.patch"
diff --git a/community/py3-pygit2/fix-1.0.patch b/community/py3-pygit2/fix-1.0.patch
new file mode 100644
index 0000000000..81c183946b
--- /dev/null
+++ b/community/py3-pygit2/fix-1.0.patch
@@ -0,0 +1,15 @@
+diff --git a/src/types.h b/src/types.h
+index 86104ffa..1ff222c8 100644
+--- a/src/types.h
++++ b/src/types.h
+@@ -32,8 +32,8 @@
+ #include <Python.h>
+ #include <git2.h>
+
+-#if !(LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR == 99 || LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 0)
+-#error You need a compatible libgit2 version (0.99.x or 1.0.x)
++#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 0)
++#error You need a compatible libgit2 version (1.0.x)
+ #endif
+
+ /*