aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pymacaroons/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:07 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:07 +0100
commitee4211cacc3103bfb4b9b7498f8b47371defcacb (patch)
tree5e36e40d69475a3a83529ee17ec4c853c3cc9735 /community/py3-pymacaroons/APKBUILD
parent562c32533a7d52eddb405e254b98516cebfd020e (diff)
downloadaports-ee4211cacc3103bfb4b9b7498f8b47371defcacb.tar.bz2
aports-ee4211cacc3103bfb4b9b7498f8b47371defcacb.tar.xz
community/py3-pymacaroons: move from testing
Diffstat (limited to 'community/py3-pymacaroons/APKBUILD')
-rw-r--r--community/py3-pymacaroons/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/py3-pymacaroons/APKBUILD b/community/py3-pymacaroons/APKBUILD
new file mode 100644
index 0000000000..10f4ea335d
--- /dev/null
+++ b/community/py3-pymacaroons/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-pymacaroons
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="Macaroon library for Python3"
+url="https://github.com/ecordell/pymacaroons"
+arch="noarch"
+license="MIT"
+depends="python3 py3-six py3-pynacl"
+makedepends="python3-dev py3-setuptools"
+options="!check" # no tests
+source="https://pypi.io/packages/source/p/pymacaroons/pymacaroons-$pkgver.tar.gz"
+builddir="$srcdir/pymacaroons-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1929a63755dcfdc2e154217f3ce65a489b4ffdb8f4f9a27d6eb1f1899eba6d7f3f92c7db4401337e948306b6a97dd3b249196c89533991c9986d5702ad98e4ca pymacaroons-0.13.0.tar.gz"