aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyrfc3339/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-25 21:05:46 +0300
committerprspkt <prspkt@protonmail.com>2019-07-25 21:06:12 +0300
commite46a780c8deeec05aabdf65de8ec36a1f3d97459 (patch)
treec1cf446674590c205a4413f55c844a316fe289b1 /community/py3-pyrfc3339/APKBUILD
parent3afc5514e1ab664950f98fe8a1946d52b4f3c6b1 (diff)
downloadaports-e46a780c8deeec05aabdf65de8ec36a1f3d97459.tar.bz2
aports-e46a780c8deeec05aabdf65de8ec36a1f3d97459.tar.xz
community/py3-pyrfc3339: add checkdepends, run test suite
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-pyrfc3339/APKBUILD')
-rw-r--r--community/py3-pyrfc3339/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/py3-pyrfc3339/APKBUILD b/community/py3-pyrfc3339/APKBUILD
index b616217a1a..dcd04589ea 100644
--- a/community/py3-pyrfc3339/APKBUILD
+++ b/community/py3-pyrfc3339/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-pyrfc3339
_pkgname=pyRFC3339
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Generate and parse RFC 3339 timestamps"
url="https://pypi.python.org/pypi/pyRFC3339"
arch="noarch"
license="MIT"
depends="py3-tz"
makedepends="py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -20,6 +21,10 @@ build() {
python3 setup.py build
}
+check() {
+ nosetests
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}