aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyscard
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:13:32 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:46:03 +0100
commit5cb6c88a27f67df3e1d964ea230764083236aed7 (patch)
tree520c4374f3098986b8c8ffd8393f969dc94f6611 /community/py3-pyscard
parent9588503236fa4cc4cab34e249e815abf265563cb (diff)
downloadaports-5cb6c88a27f67df3e1d964ea230764083236aed7.tar.bz2
aports-5cb6c88a27f67df3e1d964ea230764083236aed7.tar.xz
community/py3-pyscard: move from testing
Diffstat (limited to 'community/py3-pyscard')
-rw-r--r--community/py3-pyscard/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-pyscard/APKBUILD b/community/py3-pyscard/APKBUILD
new file mode 100644
index 0000000000..d00c33563e
--- /dev/null
+++ b/community/py3-pyscard/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Daniel Everett <deverett@gmail.com>
+# Maintainer: Daniel Everett <deverett@gmail.com>
+pkgname=py3-pyscard
+_pkgname=pyscard
+pkgver=1.9.9
+pkgrel=1
+pkgdesc="pyscard smartcard library for python"
+url="https://github.com/LudovicRousseau/pyscard"
+arch="all"
+license="LGPL-2.1-only"
+depends="pcsc-lite"
+makedepends="python3-dev py3-setuptools swig pcsc-lite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py test
+}
+
+sha512sums="88c7314c10153f509eb9bf6318e62210c7182e51b531af752a402bf8d05cfa2658cc1a4e7b9385a474038ddfa5a1bfbf1f208fcd9abe02a60161ce7c757c67b2 pyscard-1.9.9.tar.gz"