aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pysocks
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:56:22 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:56:25 +0000
commit2441cb1eb3f5c02d368f7f8b849377c789e0ec08 (patch)
tree9769f6f98570bd90da6bba9b2ee110f685e8a91e /community/py3-pysocks
parente4db187e4cc8f844591a8acfe924d5b7b58ef329 (diff)
downloadaports-2441cb1eb3f5c02d368f7f8b849377c789e0ec08.tar.bz2
aports-2441cb1eb3f5c02d368f7f8b849377c789e0ec08.tar.xz
testing/py3-pysocks: move to community
due to docker-compose
Diffstat (limited to 'community/py3-pysocks')
-rw-r--r--community/py3-pysocks/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-pysocks/APKBUILD b/community/py3-pysocks/APKBUILD
new file mode 100644
index 0000000000..02cb30838c
--- /dev/null
+++ b/community/py3-pysocks/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=py3-pysocks
+pkgver=1.6.8
+pkgrel=1
+pkgdesc="Python Socks module"
+url="https://github.com/Anorov/PySocks"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://pypi.io/packages/source/P/PySocks/PySocks-$pkgver.tar.gz"
+builddir="$srcdir/PySocks-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5 PySocks-1.6.8.tar.gz"