aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-cov/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-18 14:51:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-18 14:51:58 -0300
commitbe82477324cade6a73de6ec9185f9a711a4d7c2c (patch)
tree379fbd9641323091e0f3413addb4ba7946519cd8 /community/py3-pytest-cov/APKBUILD
parent84df3aaca836a5f69e18e180570d7258bd7fc5e0 (diff)
downloadaports-be82477324cade6a73de6ec9185f9a711a4d7c2c.tar.bz2
aports-be82477324cade6a73de6ec9185f9a711a4d7c2c.tar.xz
community/py3-pytest-cov: rename from pytest-cov
Diffstat (limited to 'community/py3-pytest-cov/APKBUILD')
-rw-r--r--community/py3-pytest-cov/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-pytest-cov/APKBUILD b/community/py3-pytest-cov/APKBUILD
new file mode 100644
index 0000000000..524f79844c
--- /dev/null
+++ b/community/py3-pytest-cov/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=py3-pytest-cov
+_pkgname=${pkgname#py3-}
+pkgver=2.7.1
+pkgrel=0
+pkgdesc="Pytest plugin for measuring coverage."
+url="https://github.com/pytest-dev/pytest-cov"
+arch="noarch"
+license="MIT"
+replaces="pytest-cov" # for backwards compatibility
+provides="pytest-cov=$pkgver-r$pkgrel" # for backwards compatibility
+depends="pytest py3-pytest py3-coverage"
+makedepends="python3-dev py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/pytest-cov/archive/v$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=. python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix="/usr" --root="$pkgdir"
+}
+
+sha512sums="bb2bc5be49b3c2f56a36b6396d6b1a6734e86fb0bf1c2ef29bf8dbc95dcb9364c6deb1525529d46f4ec0ffa6899ef0e94b5f76e5ed892b0a092e69ad6c6e080e py3-pytest-cov-2.7.1.tar.gz"