aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-requests-toolbelt
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 14:50:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 17:37:21 -0300
commit3f719de297b91f906200ae367526850c64d2b193 (patch)
tree9958f760dbd2947b5a2b6ef78579af3af0371bad /community/py3-requests-toolbelt
parent0f73e4c7e79be62b20c4e5eb8eb7d3473ecd934b (diff)
downloadaports-3f719de297b91f906200ae367526850c64d2b193.tar.bz2
aports-3f719de297b91f906200ae367526850c64d2b193.tar.xz
community/py3-requests-toolbelt: rename from py-requests-toolbelt
Diffstat (limited to 'community/py3-requests-toolbelt')
-rw-r--r--community/py3-requests-toolbelt/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-requests-toolbelt/APKBUILD b/community/py3-requests-toolbelt/APKBUILD
new file mode 100644
index 0000000000..ba196f1592
--- /dev/null
+++ b/community/py3-requests-toolbelt/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=py-requests-toolbelt
+_pkgname=toolbelt
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Useful classes and functions to be used with python-requests"
+url="https://github.com/requests/toolbelt"
+arch="noarch"
+license="Apache-2.0"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/requests/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ($python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="55bf93d386442f5deb81eabd85812ffd49e98ff88c0bb96e15271efd84deb7c5d854a2cdc81c989a7d74870e8a218fc968d080052d9ca7cd9733a2378ea9c2f5 py-requests-toolbelt-0.8.0.tar.gz"