aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-sortedcontainers
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 16:06:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:11:20 -0300
commit9a717bd76bd1edd5cce01b9f3a4431b0281429f3 (patch)
treebc3b8c9b2e67e4cac754b4d248a57558b17fc87e /community/py3-sortedcontainers
parent4f3095df9e968314641ef6c09977b268640e938e (diff)
downloadaports-9a717bd76bd1edd5cce01b9f3a4431b0281429f3.tar.bz2
aports-9a717bd76bd1edd5cce01b9f3a4431b0281429f3.tar.xz
community/py3-sortedcontainers: drop py2
Diffstat (limited to 'community/py3-sortedcontainers')
-rw-r--r--community/py3-sortedcontainers/APKBUILD38
1 files changed, 9 insertions, 29 deletions
diff --git a/community/py3-sortedcontainers/APKBUILD b/community/py3-sortedcontainers/APKBUILD
index 473f888876..fc3ea56696 100644
--- a/community/py3-sortedcontainers/APKBUILD
+++ b/community/py3-sortedcontainers/APKBUILD
@@ -1,52 +1,32 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=py-sortedcontainers
+pkgname=py3-sortedcontainers
_pkgname=sortedcontainers
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python library for sorting collections and containers"
url="http://www.grantjenks.com/docs/sortedcontainers"
arch="noarch"
license="Apache-2.0"
-makedepends="py-setuptools python2-dev python3-dev"
-checkdepends="py-nose pytest"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-nose py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-sortedcontainers" # Backwards compatibility
+provides="py-sortedcontainers=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- nosetests-2.7
nosetests-$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="6fe2b6e7d030b67aa990d62160079852feaee7828164eae03a6477dc1704863f6ed0daadb44dc919653c66996d51f833b5858351a8fd5ad28998f8010a8ca1a4 sortedcontainers-2.1.0.tar.gz"