aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-texttable
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 07:36:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 20:48:40 -0300
commit4b071ca78ad8b4d34dc77449b93236e1580881b3 (patch)
tree1a25e3c6b8689d5d3b94365f7b434d9c250d4104 /community/py3-texttable
parent50642e9e40a215ef1774cbd251f799f5994b3f80 (diff)
downloadaports-4b071ca78ad8b4d34dc77449b93236e1580881b3.tar.bz2
aports-4b071ca78ad8b4d34dc77449b93236e1580881b3.tar.xz
community/py3-texttable: upgrade to 1.6.2
Diffstat (limited to 'community/py3-texttable')
-rw-r--r--community/py3-texttable/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/py3-texttable/APKBUILD b/community/py3-texttable/APKBUILD
index bacbc14402..42c8554778 100644
--- a/community/py3-texttable/APKBUILD
+++ b/community/py3-texttable/APKBUILD
@@ -1,29 +1,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-texttable
-pkgver=1.4.0
-pkgrel=1
+pkgver=1.6.2
+pkgrel=0
pkgdesc="module for creating simple ASCII tables"
url="https://github.com/foutaise/texttable/"
-arch="all"
-license="LGPL-3.0"
+arch="noarch"
+license="MIT"
depends="python3"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
builddir="$srcdir/texttable-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- python3 setup.py check
+ py.test-3 tests.py -v
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5 texttable-1.4.0.tar.gz"
+sha512sums="daf8c10b52e8c0472da129ad905e60ff6195a7f58e5b278f6eaad2b622f527ed8ac6d747aa90cdcb8e40c81150c88da436cb8616e259662a7d48a22de0a1ee50 texttable-1.6.2.tar.gz"