aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-texttable
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:57:04 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:57:05 +0000
commitd2325bd6192e99615ee8c15952ad0b181b7fb6f6 (patch)
treefb3f97c115a07db7ac620fe65fcdea53a7f6072e /community/py3-texttable
parent2441cb1eb3f5c02d368f7f8b849377c789e0ec08 (diff)
downloadaports-d2325bd6192e99615ee8c15952ad0b181b7fb6f6.tar.bz2
aports-d2325bd6192e99615ee8c15952ad0b181b7fb6f6.tar.xz
testing/py3-texttable: move to community
due to docker-compose
Diffstat (limited to 'community/py3-texttable')
-rw-r--r--community/py3-texttable/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-texttable/APKBUILD b/community/py3-texttable/APKBUILD
new file mode 100644
index 0000000000..bacbc14402
--- /dev/null
+++ b/community/py3-texttable/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-texttable
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="module for creating simple ASCII tables"
+url="https://github.com/foutaise/texttable/"
+arch="all"
+license="LGPL-3.0"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
+builddir="$srcdir/texttable-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5 texttable-1.4.0.tar.gz"