aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-txacme/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 20:59:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 20:59:55 +0100
commit6c918499549fb5b7a64330fb1b509d018f79de17 (patch)
tree7df31b66e3316b411a93fa93c5a6c42cc8d4ad95 /community/py3-txacme/APKBUILD
parentb3490f59187aab9b21e13756438d6428151171c2 (diff)
downloadaports-6c918499549fb5b7a64330fb1b509d018f79de17.tar.bz2
aports-6c918499549fb5b7a64330fb1b509d018f79de17.tar.xz
community/py3-txacme: move from testing
Diffstat (limited to 'community/py3-txacme/APKBUILD')
-rw-r--r--community/py3-txacme/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-txacme/APKBUILD b/community/py3-txacme/APKBUILD
new file mode 100644
index 0000000000..87150ed4c5
--- /dev/null
+++ b/community/py3-txacme/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-txacme
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="ACME protocol implementation for Twisted"
+options="!check" # Requires unpackaged dependencies
+url="https://github.com/mithrandi/txacme"
+arch="noarch"
+license="MIT"
+depends="
+ python3
+ py3-acme
+ py3-attrs
+ py3-eliot
+ py3-josepy
+ py3-pem
+ py3-treq
+ py3-twisted
+ py3-txsni
+ py3-openssl
+ "
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/t/txacme/txacme-$pkgver.tar.gz"
+builddir="$srcdir/txacme-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="efbe0563e5c6644c71c6c020428cd10b681b4a7b3cfba1b8475b74ad8503fb0defa24d028b1d37f24b11dfd3f90cc98c1e7318b8b1748142de9c51da00498e35 txacme-0.9.2.tar.gz"