aboutsummaryrefslogtreecommitdiffstats
path: root/community/pytest
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 03:55:47 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-11-19 18:59:59 +0100
commitefa1edf4e055b70bde46388d38edd799761e8d9c (patch)
tree072040e63ca1a5a9dcd11748baac6d8bd12bf4e5 /community/pytest
parent4c6b35272a8899d65d00e5f869e15df964910f09 (diff)
downloadaports-efa1edf4e055b70bde46388d38edd799761e8d9c.tar.bz2
aports-efa1edf4e055b70bde46388d38edd799761e8d9c.tar.xz
community/pytest: upgrade to 3.0.3
Diffstat (limited to 'community/pytest')
-rw-r--r--community/pytest/APKBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/community/pytest/APKBUILD b/community/pytest/APKBUILD
index fb4bebf7a6..6132bf24a5 100644
--- a/community/pytest/APKBUILD
+++ b/community/pytest/APKBUILD
@@ -1,51 +1,49 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=pytest
-_pkgname=pytest
-pkgver=2.9.2
+pkgver=3.0.3
pkgrel=0
pkgdesc="A python test library"
url="http://pytest.org"
arch="noarch"
license="MIT"
-depends=""
-depends_dev=""
+depends="py-py"
makedepends="python2-dev py-setuptools python3-dev"
-install=""
-subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$_pkgname-$pkgver
+subpackages="py3-$pkgname:_py3 py2-$pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
mkdir -p "$pkgdir"
}
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
_py2() {
- _py python2
replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
}
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
-md5sums="b65c2944dfaa0efb62c0239afb424f5b pytest-2.9.2.tar.gz"
-sha256sums="12c18abb9a09a5b2802dba75c7a2d7d6c8c0f1258abd8243e7688415d87ad1d8 pytest-2.9.2.tar.gz"
-sha512sums="54a29933b6964ac0ca39035428cc2a2dd740a47728f8dda08828b962da3fa0878aeb5afc6d938c0171957e643c1453f1a8ca84117fc1bf86885b0e71ff80b5ad pytest-2.9.2.tar.gz"
+md5sums="b33b3b1f847d3745a78423762f6b7f6d pytest-3.0.3.tar.gz"
+sha256sums="f213500a356800a483e8a146ff971ae14a8df3f2c0ae4145181aad96996abee7 pytest-3.0.3.tar.gz"
+sha512sums="ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af pytest-3.0.3.tar.gz"