aboutsummaryrefslogtreecommitdiffstats
path: root/community/qca
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-05 10:49:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:15 +0000
commit61e3814043d1d612f7c14aeb41cb9f216a67c7d9 (patch)
tree6052f8de0e94598972e93887c4ecb082515c06ee /community/qca
parent8cbe3cf4f619aaa192c40e374c61855c788707f6 (diff)
downloadaports-61e3814043d1d612f7c14aeb41cb9f216a67c7d9.tar.bz2
aports-61e3814043d1d612f7c14aeb41cb9f216a67c7d9.tar.xz
community/qca: move from main
Diffstat (limited to 'community/qca')
-rw-r--r--community/qca/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/qca/APKBUILD b/community/qca/APKBUILD
new file mode 100644
index 0000000000..51296b8eb9
--- /dev/null
+++ b/community/qca/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=qca
+pkgver=2.1.3
+pkgrel=5
+pkgdesc="Qt cryptographic architecture"
+url="http://delta.affinix.com/qca/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="qt-dev"
+makedepends="$depends_dev cmake cyrus-sasl-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.kde.org/stable/qca/$pkgver/src/qca-${pkgver}.tar.xz"
+
+builddir="$srcdir"/qca-$pkgver
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITH_cyrus-sasl_PLUGIN=yes .
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+check() {
+ cd "$builddir"
+ make test || return 1
+}
+
+sha512sums="0aec277e0695da2e45298f0a9006213829fe4c449a79969e472947db54f45000ba6e22361b782465bdc03f269b7301d318c843f5a83db459a118e58a03f3116a qca-2.1.3.tar.xz"