aboutsummaryrefslogtreecommitdiffstats
path: root/community/qca
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:47:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commita0763f7040e1a4e8f8899f17aab89b58980fddee (patch)
treee04e68af67f8f8b7288f5178d55cb0797d781c40 /community/qca
parentb9ced6593a9e3fa58bc72824d98410779b358fde (diff)
downloadaports-a0763f7040e1a4e8f8899f17aab89b58980fddee.tar.bz2
aports-a0763f7040e1a4e8f8899f17aab89b58980fddee.tar.xz
community/qca: modernize
Diffstat (limited to 'community/qca')
-rw-r--r--community/qca/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/qca/APKBUILD b/community/qca/APKBUILD
index bf718bffc0..19f668a277 100644
--- a/community/qca/APKBUILD
+++ b/community/qca/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qca
pkgver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Qt cryptographic architecture"
url="https://userbase.kde.org/QCA"
arch="all"
@@ -12,20 +12,23 @@ subpackages="$pkgname-dev $pkgname-doc lib$pkgname:libs"
source="https://download.kde.org/stable/qca/$pkgver/qca-$pkgver.tar.xz"
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITH_cyrus-sasl_PLUGIN=yes .
- make
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_cyrus-sasl_PLUGIN=yes
+ make -C build
+}
+
+check() {
+ make -C build test
}
package() {
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/lib/qt5
mv "$pkgdir"/usr/mkspecs "$pkgdir"/usr/lib/qt5
}
-check() {
- make test
-}
-
libs() {
default_libs
mv "$pkgdir"/usr/lib/qca-qt5 "$subpkgdir"/usr/lib