aboutsummaryrefslogtreecommitdiffstats
path: root/community/qqc2-desktop-style
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/qqc2-desktop-style
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/qqc2-desktop-style')
-rw-r--r--community/qqc2-desktop-style/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/qqc2-desktop-style/APKBUILD b/community/qqc2-desktop-style/APKBUILD
new file mode 100644
index 0000000000..829af5c643
--- /dev/null
+++ b/community/qqc2-desktop-style/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qqc2-desktop-style
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="A style for Qt Quick Controls 2 to make it follow your desktop theme"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-3.0-only OR (GPL-2.0-only OR GPL-3.0-only)"
+depends="qt5-qtgraphicaleffects qt5-qtquickcontrols2"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtx11extras-dev kirigami2-dev kiconthemes-dev kconfigwidgets-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="a44e81566daaf08c0b6da4d95a6c309763439d3e477c6813604bcb3a0ce876e845949aec235c945ccdc6164a9554768f6169170edf99d2c5575496e78f73e45a qqc2-desktop-style-5.60.0.tar.xz"