aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtbase
diff options
context:
space:
mode:
authorJussi Kukkonen <jku@goto.fi>2018-02-27 19:51:46 +0200
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-27 21:12:35 +0000
commitbeb769be1b5ad337a10350d0cf0421731c5f8856 (patch)
treec8d4339d28a1a40773681c60e20d6b6eb4c702a4 /community/qt5-qtbase
parentba241da1c79d6f8320eba0c119a50a815156c1ac (diff)
downloadaports-beb769be1b5ad337a10350d0cf0421731c5f8856.tar.bz2
aports-beb769be1b5ad337a10350d0cf0421731c5f8856.tar.xz
community/qt5-qtbase: Allow more ssl API use (libressl compat patch)
Current libressl actually supports SSL_CTRL_SET_CURVES: don't prevent using it with libressl.
Diffstat (limited to 'community/qt5-qtbase')
-rw-r--r--community/qt5-qtbase/APKBUILD2
-rw-r--r--community/qt5-qtbase/libressl-compat.patch9
2 files changed, 1 insertions, 10 deletions
diff --git a/community/qt5-qtbase/APKBUILD b/community/qt5-qtbase/APKBUILD
index 9dd8ba274a..0a66f4e1e5 100644
--- a/community/qt5-qtbase/APKBUILD
+++ b/community/qt5-qtbase/APKBUILD
@@ -204,4 +204,4 @@ x11() {
sha512sums="256ffb8760e94c0f87790ed35e210d0c9613e14314ff442dd763cc93fbd5caa6c11c95f5d44b12a7687fb93c9f857878132cf6d76e5933f647ca7beb54b18c7c qtbase-opensource-src-5.9.3.tar.xz
7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch
-af284ebb51e3d903275f0f43901755fee0d0071a2fa4f5d6e8a4b00d9185d9d9fffba8e5cbda8c4aa2b3acde69fd26a449b23ad104f509fd4156f6908e0b43da libressl-compat.patch"
+632fd540787b303da4c1165f5086e046ecdfd84f12c87f051a866adb7e1c4b637b2f27ee202ca387e8233468ce17e8474054fae75d57640dc83987a281afc58b libressl-compat.patch"
diff --git a/community/qt5-qtbase/libressl-compat.patch b/community/qt5-qtbase/libressl-compat.patch
index c9f2e33f50..5b21dc2d8f 100644
--- a/community/qt5-qtbase/libressl-compat.patch
+++ b/community/qt5-qtbase/libressl-compat.patch
@@ -98,15 +98,6 @@
int q_PKCS12_parse(PKCS12 *p12, const char *pass, EVP_PKEY **pkey, X509 **cert, STACK_OF(X509) **ca);
--- qtbase/src/network/ssl/qsslcontext_openssl.cpp 2017-01-18 15:20:58.000000000 +0100
+++ qtbase/src/network/ssl/qsslcontext_openssl.cpp 2017-02-21 19:23:04.291975945 +0100
-@@ -344,7 +344,7 @@
-
- const QVector<QSslEllipticCurve> qcurves = sslContext->sslConfiguration.ellipticCurves();
- if (!qcurves.isEmpty()) {
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(OPENSSL_NO_EC)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10002000L) && !defined(OPENSSL_NO_EC) && !defined(LIBRESSL_VERSION_NUMBER)
- // Set the curves to be used
- if (q_SSLeay() >= 0x10002000L) {
- // SSL_CTX_ctrl wants a non-const pointer as last argument,
@@ -462,7 +462,7 @@
m_npnContext.data = reinterpret_cast<unsigned char *>(m_supportedNPNVersions.data());
m_npnContext.len = m_supportedNPNVersions.count();