aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebkit
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-10 10:27:07 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-28 09:49:16 +0000
commit0017d10490a8cbf1313eedd4b53244c56b132bf5 (patch)
treeba30b36f0b41b2e4edbc85e4194c59cd30c024d3 /community/qt5-qtwebkit
parent8253e0a1bc5d29b219d9236a3b6ba1e026620631 (diff)
downloadaports-0017d10490a8cbf1313eedd4b53244c56b132bf5.tar.bz2
aports-0017d10490a8cbf1313eedd4b53244c56b132bf5.tar.xz
community/qt5-qtwebkit: upgrade to 5.212.0-alpha4
Diffstat (limited to 'community/qt5-qtwebkit')
-rw-r--r--community/qt5-qtwebkit/0001-Add-ARM-64-support.patch13
-rw-r--r--community/qt5-qtwebkit/APKBUILD97
-rw-r--r--community/qt5-qtwebkit/fix-execinfo.patch20
-rw-r--r--community/qt5-qtwebkit/fix-rpath.patch11
-rw-r--r--community/qt5-qtwebkit/icu.patch41
-rw-r--r--community/qt5-qtwebkit/musl-mcontext.patch67
-rw-r--r--community/qt5-qtwebkit/qt5.12.patch26
7 files changed, 104 insertions, 171 deletions
diff --git a/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch b/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch
deleted file mode 100644
index 73f5c97f87..0000000000
--- a/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
-index 4594ec8..639f28f 100644
---- a/Source/WTF/wtf/Platform.h
-+++ b/Source/WTF/wtf/Platform.h
-@@ -342,7 +342,7 @@
- #endif
- #endif
-
--#if CPU(ARM) || CPU(MIPS) || CPU(SH4) || CPU(SPARC) || CPU(MIPS64)
-+#if CPU(ARM) || CPU(MIPS) || CPU(SH4) || CPU(SPARC) || CPU(MIPS64) || CPU(AARCH64)
- #define WTF_CPU_NEEDS_ALIGNED_ACCESS 1
- #endif
-
diff --git a/community/qt5-qtwebkit/APKBUILD b/community/qt5-qtwebkit/APKBUILD
index 3f454c07c1..e0b27a4364 100644
--- a/community/qt5-qtwebkit/APKBUILD
+++ b/community/qt5-qtwebkit/APKBUILD
@@ -1,87 +1,64 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtwebkit
-pkgver=5.9.1
+pkgver=5.212.0_alpha4
+_pkgver=${pkgver/_/-}
pkgrel=9
pkgdesc="Qt5 - QtWebKit components"
url="https://www.qt.io/developers/"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-depends_dev="qt5-qtdeclarative-dev gstreamer-dev gst-plugins-base-dev
- libxslt-dev mesa-dev icu-dev libxext-dev glib-dev libxcomposite-dev
+depends_dev="
+ qt5-qtbase-dev
+ qt5-qtlocation-dev
+ qt5-qtsensors-dev
+ qt5-qtwebchannel-dev
+ hyphen-dev
+ libjpeg-turbo-dev
+ icu-dev
+ libxml2-dev
+ libxslt-dev
+ libxcomposite-dev
libxrender-dev
+ gst-plugins-base-dev
+ libwebp-dev
+ libexecinfo-dev
"
makedepends="$depends_dev
+ cmake
bison
flex
- fontconfig-dev
gperf
- libjpeg-turbo-dev
- libpng-dev
- libwebp-dev
- pcre-dev
- qt5-qtbase-dev
ruby
- sqlite-dev
- zlib-dev
- python2
"
subpackages="$pkgname-dev"
-_ver=${pkgver/_/-}
-_ver=${_ver/beta0/beta}
-_ver=${_ver/rc0/rc}
-_v=${_ver/rc/RC}
-case $pkgver in
-*_beta*|*_rc*) _rel=development_releases;;
-*) _rel=official_releases;;
-esac
-
-source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$_ver/submodules/qtwebkit-opensource-src-$_v.tar.xz
+source="https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz
pic.patch
- fix-rpath.patch
- fix-execinfo.patch
- 0001-Add-ARM-64-support.patch
- qt5.12.patch
- icu.patch
+ musl-mcontext.patch
"
-builddir="$srcdir/qtwebkit-opensource-src-$_v"
-
-prepare() {
- default_prepare # apply patches
- # remove some bundled
- mkdir Source/ThirdParty/orig
- mv Source/ThirdParty/gtest/ \
- Source/ThirdParty/qunit/ \
- Source/ThirdParty/orig/
- syncqt-qt5.pl -version $_v Source/sync.profile
-}
+builddir="$srcdir/qtwebkit-$_pkgver"
build() {
- qmake-qt5
+ case "$CARCH" in
+ aarch64|ppc64le|s390x) _jit=FALSE ;;
+ *) _jit=TRUE ;;
+ esac
- # /usr/include/fortify/stdlib.h:20:25: fatal error: stdlib.h: No such file or directory
- # see: http://stackoverflow.com/questions/37218953/isystem-on-a-system-include-directory-causes-errors
- # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71090
- # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
- qmake-qt5 Source/JavaScriptCore/LLIntOffsetsExtractor.pro -o \
- Source/JavaScriptCore/Makefile.LLIntOffsetsExtractor
- sed -i 's:-isystem /usr/include ::' \
- Source/JavaScriptCore/Makefile.LLIntOffsetsExtractor
-
- make
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPORT=Qt \
+ -DENABLE_JIT=$_jit
+ make -C build
}
package() {
- make install INSTALL_ROOT="$pkgdir"
- # remove rpath
-# chrpath --delete "$pkgdir"/usr/lib/qt5/libexec/*
- sed -i -e 's:-L/home[^ ]\+::g' "$pkgdir"/usr/lib/pkgconfig/*.pc
+ DESTDIR="$pkgdir" make -C build install
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="79316ab746a230fdb290e28629d7cec5fca75119ba8868060742c682ab86490de9ffd8e517569aa7412f35fd709568dbb5f7d2d467bdb4461e192f8b05d6f1e5 qtwebkit-opensource-src-5.9.1.tar.xz
+sha512sums="33f11270bd030599beff9c1983a6c5ff2d61f407cc8a6825f7f405d46f9184c720fc7f60c7359f08f828db96a2170092875066a0d5c0a21ff09bc48a2603fbf6 qtwebkit-5.212.0-alpha4.tar.xz
9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
-00d59c0cdb58ae8e7cf6bc3d03f133697e74c267ccebe12238bcdc274d4c90210b82c2d8bdf0e949cd43da13a4fd8a4c35fb54a00ed5102a4ac4d23aa002d0fe fix-rpath.patch
-f17c2f4b90090c8f12e4ba1f2cbd7a9f496c8de024ba6e0d55b98e5b89ab89298aff84f39e81905e0491fe6bd11544633a8b191403a866e16ed654d44cf8dc6f fix-execinfo.patch
-af5097d44f73de156ca31a5423136301dfc12ae693e20c4702bf3f1c6e16395f3912e9268582480ba3177021f37d4cae3b84d4b23eeb063fdc40f2444d3b34c8 0001-Add-ARM-64-support.patch
-5e056bc410892dee53825b191d227a669bba75579bdcf20a671afc063200a6dfd8348dff65f3560a3a9726c07b627be3ba9ac151b05d9bc6535da7d7669018f8 qt5.12.patch
-e92cc6862f72902a18669575286a80f6a0bb510514731ddef0968a13fd83cf3744b03efbfe6709cac4ff5fe73c68b292f208a806d31dab139ded51229b356a2c icu.patch"
+11f6b4b5101f5e89917062483c0d55c4180dc4b8107bb3f6ad92ed4e56361ef1b604909056b383313c4072b1229dc9f6606ceacdd84efc1dc80dd1151294b195 musl-mcontext.patch"
diff --git a/community/qt5-qtwebkit/fix-execinfo.patch b/community/qt5-qtwebkit/fix-execinfo.patch
deleted file mode 100644
index 6fbf4ed8fd..0000000000
--- a/community/qt5-qtwebkit/fix-execinfo.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- webkitgtk-2.2.0.orig/Source/WTF/wtf/Assertions.cpp
-+++ webkitgtk-2.2.0/Source/WTF/wtf/Assertions.cpp
-@@ -64,7 +64,7 @@
- #include <windows.h>
- #endif
-
--#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
-+#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
- #include <cxxabi.h>
- #include <dlfcn.h>
- #include <execinfo.h>
-@@ -242,7 +242,7 @@
-
- void WTFGetBacktrace(void** stack, int* size)
- {
--#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
-+#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
- *size = backtrace(stack, *size);
- #elif OS(WINDOWS) && !OS(WINCE)
- // The CaptureStackBackTrace function is available in XP, but it is not defined
diff --git a/community/qt5-qtwebkit/fix-rpath.patch b/community/qt5-qtwebkit/fix-rpath.patch
deleted file mode 100644
index 6b08fd1a39..0000000000
--- a/community/qt5-qtwebkit/fix-rpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Tools/qmake/mkspecs/features/unix/default_post.prf.orig
-+++ ./Tools/qmake/mkspecs/features/unix/default_post.prf
-@@ -59,8 +59,6 @@
- }
- }
-
--contains(TEMPLATE, app): CONFIG += rpath
--
- CONFIG(debug, debug|release)|force_debug_info {
- # Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
- !force_static_libs_as_shared:config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/community/qt5-qtwebkit/icu.patch b/community/qt5-qtwebkit/icu.patch
deleted file mode 100644
index c6f8fb6779..0000000000
--- a/community/qt5-qtwebkit/icu.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
-index af63b141..26f7312b 100644
---- a/Source/WebCore/dom/Document.cpp
-+++ b/Source/WebCore/dom/Document.cpp
-@@ -3846,12 +3846,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
- unsigned i = 0;
-
- UChar32 c;
-- U16_NEXT(characters, i, length, c)
-+ U16_NEXT(characters, i, length, c);
- if (!isValidNameStart(c))
- return false;
-
- while (i < length) {
-- U16_NEXT(characters, i, length, c)
-+ U16_NEXT(characters, i, length, c);
- if (!isValidNamePart(c))
- return false;
- }
-@@ -3914,7 +3914,7 @@ bool Document::parseQualifiedName(const String& qualifiedName, String& prefix, S
- const UChar* s = qualifiedName.characters();
- for (unsigned i = 0; i < length;) {
- UChar32 c;
-- U16_NEXT(s, i, length, c)
-+ U16_NEXT(s, i, length, c);
- if (c == ':') {
- if (sawColon) {
- ec = NAMESPACE_ERR;
-diff --git a/Source/WebCore/platform/graphics/SegmentedFontData.cpp b/Source/WebCore/platform/graphics/SegmentedFontData.cpp
-index efb20a8c..99b3e86c 100644
---- a/Source/WebCore/platform/graphics/SegmentedFontData.cpp
-+++ b/Source/WebCore/platform/graphics/SegmentedFontData.cpp
-@@ -61,7 +61,7 @@ bool SegmentedFontData::containsCharacters(const UChar* characters, int length)
- {
- UChar32 c;
- for (int i = 0; i < length; ) {
-- U16_NEXT(characters, i, length, c)
-+ U16_NEXT(characters, i, length, c);
- if (!containsCharacter(c))
- return false;
- }
diff --git a/community/qt5-qtwebkit/musl-mcontext.patch b/community/qt5-qtwebkit/musl-mcontext.patch
new file mode 100644
index 0000000000..20100ca6e7
--- /dev/null
+++ b/community/qt5-qtwebkit/musl-mcontext.patch
@@ -0,0 +1,67 @@
+diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+index 883914fd3d1..9c0209ad2f3 100644
+--- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
++++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+@@ -683,7 +683,19 @@ void* MachineThreads::Thread::Registers::framePointer() const
+ #endif
+
+ #else
+-#error Need a way to get the frame pointer for another thread on this platform
++
++// The following sequence depends on musl libc's sys/ucontext.h.
++#if CPU(X86)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_EBP]);
++#elif CPU(X86_64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_RBP]);
++#elif CPU(ARM)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_fp);
++#elif CPU(ARM64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.regs[29]);
++#elif CPU(MIPS)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[30]);
++#endif
+ #endif
+ }
+
+@@ -765,7 +777,19 @@ void* MachineThreads::Thread::Registers::instructionPointer() const
+ #endif
+
+ #else
+-#error Need a way to get the instruction pointer for another thread on this platform
++
++// The following sequence depends on musl libc's sys/ucontext.h.
++#if CPU(X86)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_EIP]);
++#elif CPU(X86_64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_RIP]);
++#elif CPU(ARM)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_pc);
++#elif CPU(ARM64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.pc);
++#elif CPU(MIPS)
++ return reinterpret_cast<void *>((uintptr_t)regs.machineContext.pc);
++#endif
+ #endif
+ }
+ void* MachineThreads::Thread::Registers::llintPC() const
+@@ -856,7 +880,19 @@ void* MachineThreads::Thread::Registers::llintPC() const
+ #endif
+
+ #else
+-#error Need a way to get the LLIntPC for another thread on this platform
++
++// The following sequence depends on musl libc's sys/ucontext.h.
++#if CPU(X86)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESI]);
++#elif CPU(X86_64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_R8]);
++#elif CPU(ARM)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.arm_r8);
++#elif CPU(ARM64)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.regs[4]);
++#elif CPU(MIPS)
++ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[12]);
++#endif
+ #endif
+ }
+ #endif // ENABLE(SAMPLING_PROFILER)
diff --git a/community/qt5-qtwebkit/qt5.12.patch b/community/qt5-qtwebkit/qt5.12.patch
deleted file mode 100644
index f1ca8811b7..0000000000
--- a/community/qt5-qtwebkit/qt5.12.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Source/WebKit/qt/tests/util.h b/Source/WebKit/qt/tests/util.h
-index 4925aa4..9f834f7 100644
---- a/Source/WebKit/qt/tests/util.h
-+++ b/Source/WebKit/qt/tests/util.h
-@@ -23,7 +23,7 @@
- #endif
-
- #include <QEventLoop>
--#include <QSignalSpy>
-+#include <QtTest/QSignalSpy>
- #include <QTimer>
-
- #if !defined(TESTS_SOURCE_DIR)
-diff --git a/Source/WebKit2/UIProcess/API/qt/tests/util.h b/Source/WebKit2/UIProcess/API/qt/tests/util.h
-index 8711d5b..6bb97fa 100644
---- a/Source/WebKit2/UIProcess/API/qt/tests/util.h
-+++ b/Source/WebKit2/UIProcess/API/qt/tests/util.h
-@@ -19,7 +19,7 @@
- // Functions and macros that really need to be in QTestLib
-
- #include <QEventLoop>
--#include <QSignalSpy>
-+#include <QtTest/QSignalSpy>
- #include <QTimer>
-
- class QQuickWebView;