aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-websockets
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:09:14 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:09:14 +0000
commit94d4414a812c2339b36678aaa87fe430726fef6a (patch)
treefe7b77d3e1cff31788d847edab36d11bd6e1583d /community/qt5-websockets
parente80bac2ab2fb372e350a756aa7a8f05555c98d8e (diff)
downloadaports-94d4414a812c2339b36678aaa87fe430726fef6a.tar.bz2
aports-94d4414a812c2339b36678aaa87fe430726fef6a.tar.xz
community/qt5-websockets: moved from testing
Diffstat (limited to 'community/qt5-websockets')
-rw-r--r--community/qt5-websockets/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/qt5-websockets/APKBUILD b/community/qt5-websockets/APKBUILD
new file mode 100644
index 0000000000..7c40978c6a
--- /dev/null
+++ b/community/qt5-websockets/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=qt5-websockets
+pkgver=5.9.1
+_ver=${pkgver/_p/-}
+_ver=${_ver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+pkgrel=0
+pkgdesc="Provides WebSocket communication compliant with RFC 6455"
+url="http://qt-project.org/"
+arch="all"
+license="GPL3"
+makedepends="$depends_dev qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+options="!check"
+source="http://download.qt.io/official_releases/qt/${pkgver%.*}/$_ver/submodules/qtwebsockets-opensource-src-$_ver.tar.xz"
+builddir="$srcdir"/qtwebsockets-opensource-src-${_V%-*}
+
+build() {
+ cd "$builddir"
+ mkdir build && cd build
+ qmake-qt5 ..
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="9d56c50a604bbb2c0fbf25e9761cffb5c271678344a198da0f5014a6fe9f48fd50f31b39ee5aa8ff140827abfe0071f334ac4f8f37f09f6946e19f5fe15b56ec qtwebsockets-opensource-src-5.9.1.tar.xz"