aboutsummaryrefslogtreecommitdiffstats
path: root/community/quvi/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-31 17:56:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commitd452391d6af2cb8b8bca086cd1474bf896536a39 (patch)
treeb9bb32f56e397eb5d6df22d6400fd4750eb44965 /community/quvi/APKBUILD
parent8495e2fadb8864235a22bf5e257e455866421c2b (diff)
downloadaports-d452391d6af2cb8b8bca086cd1474bf896536a39.tar.bz2
aports-d452391d6af2cb8b8bca086cd1474bf896536a39.tar.xz
main/*quvi*: move to community
Diffstat (limited to 'community/quvi/APKBUILD')
-rw-r--r--community/quvi/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/quvi/APKBUILD b/community/quvi/APKBUILD
new file mode 100644
index 0000000000..144ca402e0
--- /dev/null
+++ b/community/quvi/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=quvi
+pkgver=0.9.5
+pkgrel=5
+pkgdesc="Command line tool for parsing video download links"
+url="http://quvi.sourceforge.net/"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=
+depends_dev="libquvi-dev zlib-dev"
+makedepends="$depends_dev glib-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/project/quvi/${pkgver%.*}/quvi/quvi-$pkgver.tar.xz
+ fix-memcorruption.patch
+ "
+
+builddir="$srcdir"/quvi-$pkgver
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ CFLAGS="$CFLAGS -g" \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="baa1d7b25e9fd173e952e27d4aa4b933 quvi-0.9.5.tar.xz
+5e424b2a18afc00afbd99a81918c702a fix-memcorruption.patch"
+sha256sums="cb3918aad990b9bc49828a5071159646247199a63de0dd4c706adc5c8cd0a2c0 quvi-0.9.5.tar.xz
+0be40d52af769e1cffa387c6a77efab099b5b60affb93ff0270a234b95c43222 fix-memcorruption.patch"
+sha512sums="ef50160b7f2b6b8c9049eb995cb26da3100b10e7af8206d98d2e128cde300ceb05a24dded06d7d49c0e691fcc2de5a4c5c9e9f439d40ca52cd0a3a24330c6d79 quvi-0.9.5.tar.xz
+81984ac85b7346fe448455f16b561d483159843e92fe46803b737f688e5d6c9174c11d90b3071c0d000e9fe95547502bf9461240652da4f792ce5ccca46af794 fix-memcorruption.patch"