aboutsummaryrefslogtreecommitdiffstats
path: root/community/remind
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-28 07:41:15 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-06-28 13:55:54 +0000
commitc3bb6cb1e65df26d26fdc0b4ba7e8aa75a439ed2 (patch)
treebbb385acd4028614cd1a3be0d766067e71fa84ff /community/remind
parent76deacce283bcc7a3ff28ca03e83965a74f82472 (diff)
downloadaports-c3bb6cb1e65df26d26fdc0b4ba7e8aa75a439ed2.tar.bz2
aports-c3bb6cb1e65df26d26fdc0b4ba7e8aa75a439ed2.tar.xz
testing/[various]: move more packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. aha archivemount bannergrab bmon py-gpiozera py-rpizero py-skywriter-hat remind
Diffstat (limited to 'community/remind')
-rw-r--r--community/remind/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/remind/APKBUILD b/community/remind/APKBUILD
new file mode 100644
index 0000000000..5fa03c853d
--- /dev/null
+++ b/community/remind/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=remind
+pkgver=03.01.15
+pkgrel=0
+pkgdesc="Sophisticated calendar and alarm program"
+url="https://www.roaringpenguin.com/products/remind"
+arch="all"
+license="GPL2"
+subpackages="$pkgname-doc tkremind"
+source="https://www.roaringpenguin.com/files/download/remind-$pkgver.tar.gz"
+
+_builddir="$srcdir"/remind-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --build=$CBUILD --host=$CHOST --prefix=/usr && make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+tkremind() {
+ arch=noarch
+ depends="remind tk"
+
+ local src="$pkgdir"/usr/bin
+ local dest="$subpkgdir"/usr/bin
+ mkdir -p "$dest"
+ mv "$src"/cm2rem.tcl "$src"/tkremind "$dest"
+}
+
+md5sums="089c51c060fdda2357a833800a5bfe39 remind-03.01.15.tar.gz"
+sha256sums="8adab4c0b30a556c34223094c5c74779164d5f3b8be66b8039f44b577e678ec1 remind-03.01.15.tar.gz"
+sha512sums="335f3ca88237f1ae53768b9ecdeb03f0bb1e706a8afd3ba36121ec76048a08fbc0d5ec72b05e552394b4cf2131be335c49533e1212b7e713ef16002a0621fc84 remind-03.01.15.tar.gz"