aboutsummaryrefslogtreecommitdiffstats
path: root/community/remmina
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-02-11 05:13:46 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-02-28 21:39:48 +0000
commit61cce9c606fd8d21443c6179ad8fe2890082d184 (patch)
tree4053cf8f864231ba768d4427c0f2fc9ee358c5b8 /community/remmina
parent07cb0307b07a1109e6fc07d8eabd4dd32a617d7e (diff)
downloadaports-61cce9c606fd8d21443c6179ad8fe2890082d184.tar.bz2
aports-61cce9c606fd8d21443c6179ad8fe2890082d184.tar.xz
community/remmina: upgrade to 1.3.2
Diffstat (limited to 'community/remmina')
-rw-r--r--community/remmina/APKBUILD16
-rw-r--r--community/remmina/libintl-underlink.patch12
-rw-r--r--community/remmina/remmina-1.0.0-dsofix.patch8
3 files changed, 17 insertions, 19 deletions
diff --git a/community/remmina/APKBUILD b/community/remmina/APKBUILD
index 0c980728a0..15b3ba04de 100644
--- a/community/remmina/APKBUILD
+++ b/community/remmina/APKBUILD
@@ -1,12 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=remmina
-pkgver=1.2.32.1
+pkgver=1.3.2
pkgrel=1
pkgdesc="Remmina is a remote desktop client written in GTK+"
url="https://www.remmina.org/"
arch="all"
-license="GPL"
-depends=""
+license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev intltool zlib-dev libjpeg-turbo-dev gnutls-dev
vte3-dev libgcrypt-dev libssh-dev libxkbfile-dev freerdp-dev
avahi-ui-dev libvncserver-dev cmake json-glib-dev libsoup-dev
@@ -18,10 +17,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/Remmina/archive/v$pk
libintl-underlink.patch
no-execinfo.patch
"
-
+options="!check" # No test suite available
builddir="$srcdir"/Remmina-$pkgver
+
build() {
- cd "$builddir"
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -38,11 +37,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="ff3aa4f18c52afa43014e9485dfd47c9e343b09b3ffc6787bb55f145df85c0b3d68fd3245badf2210b3264d718bb0a05238d75c3dbb5bd472af759eaae6443f2 remmina-1.2.32.1.tar.gz
-4a45c366d02c4dbccad156a7d4f37f8d88bb92ef577a04bc892572eab7327a654c656ead110f515ef1d330a99e339cca97021cc33775a7d534bbe3a093c5ee99 remmina-1.0.0-dsofix.patch
-21fd8e27e70cea85d9fc8b649ed28b17e796604235d759ab5fe18b1fe52c23d9443b3a46e4ef544c5178d25c65967107f6f0aff134f7df9c722bbee1c7cc4e2b libintl-underlink.patch
+sha512sums="a6a0de71c017c7dfcde4d385c3aaf03208abb8a72cfa2e7f74b1a7f02cf1c7a81d0f4663ca5d16b93ad5373f01a5f8b93fd6f7f10cf0de7cd795e279cfe54a26 remmina-1.3.2.tar.gz
+8c06cfb4cd7eb74f641d6524c2fb5c941022df1d3f428c9f57a88b9714ec602b0baf962a9947aa83de3ccfaed237956743b4eb0083c4dde0cc9740b958bba007 remmina-1.0.0-dsofix.patch
+4801c06297f0aca412edb6991355cd94ecedf3e8f564aa23e442454418c74608726c082b54b1001b542db707cdbc00541392a24a27e503a904ca5effc1e66d84 libintl-underlink.patch
ea3700ac90519e2796d241775f61e695df15676d1542fb6637266415fd69f4296b5c737b38fd55c433e52b6714b2067d079eaf6c616c1dcff42920b441b93e83 no-execinfo.patch"
diff --git a/community/remmina/libintl-underlink.patch b/community/remmina/libintl-underlink.patch
index 925a1b26a3..464e2bb13c 100644
--- a/community/remmina/libintl-underlink.patch
+++ b/community/remmina/libintl-underlink.patch
@@ -1,11 +1,11 @@
---- ./src/CMakeLists.txt.orig
-+++ ./src/CMakeLists.txt
-@@ -91,7 +91,7 @@
- add_executable(remmina ${REMMINA_SRCS})
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -121,7 +121,7 @@
+ add_executable(remmina ${REMMINA_SRCS})
include_directories(${GTK_INCLUDE_DIRS})
-target_link_libraries(remmina ${GTK_LIBRARIES})
+target_link_libraries(remmina ${GTK_LIBRARIES} -lintl)
- find_package(X11)
- include_directories(${X11_INCLUDE_DIR})
+ if(WITH_MANPAGES)
+ install(FILES remmina.1 DESTINATION ${CMAKE_INSTALL_FULL_MANDIR}/man1)
diff --git a/community/remmina/remmina-1.0.0-dsofix.patch b/community/remmina/remmina-1.0.0-dsofix.patch
index e7592c13d2..5b71b298e2 100644
--- a/community/remmina/remmina-1.0.0-dsofix.patch
+++ b/community/remmina/remmina-1.0.0-dsofix.patch
@@ -1,7 +1,7 @@
---- a/plugins/vnc/CMakeLists.txt 2012-06-04 13:03:46.542093149 -0600
-+++ b/plugins/vnc/CMakeLists.txt 2012-06-04 13:03:34.112332497 -0600
-@@ -28,7 +28,7 @@
- set_target_properties(remmina-plugin-vnc PROPERTIES PREFIX "")
+--- a/plugins/vnc/CMakeLists.txt
++++ b/plugins/vnc/CMakeLists.txt
+@@ -42,7 +42,7 @@
+ set_target_properties(remmina-plugin-vnc PROPERTIES NO_SONAME 1)
include_directories(${REMMINA_COMMON_INCLUDE_DIRS} ${LIBVNCSERVER_INCLUDE_DIRS})
-target_link_libraries(remmina-plugin-vnc ${REMMINA_COMMON_LIBRARIES} ${LIBVNCSERVER_LIBRARIES})