aboutsummaryrefslogtreecommitdiffstats
path: root/community/rest/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-21 20:54:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 21:08:54 +0100
commitaa85ff073ab82466be469e0eefc20d9c5444670e (patch)
tree4508924609cff0da5c03df75cf239914dca4a7da /community/rest/APKBUILD
parentde836ba4a8dfb11ed45a161780df23d94510db49 (diff)
downloadaports-aa85ff073ab82466be469e0eefc20d9c5444670e.tar.bz2
aports-aa85ff073ab82466be469e0eefc20d9c5444670e.tar.xz
community/rest: disable failing tests and rebuild
- Remove oauth and oauth-sync tests since they fail - Remove libsoup-dev from depends_dev since it is found by pkgconfig - Move gobject-introspection-dev to makedepends since it is not required by the -dev package - With the 2 above we can remove the depends_dev variable and use only makedepends - Fix policy violations found by apkbuild-lint
Diffstat (limited to 'community/rest/APKBUILD')
-rw-r--r--community/rest/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/community/rest/APKBUILD b/community/rest/APKBUILD
index 1fe6946517..859c3e8343 100644
--- a/community/rest/APKBUILD
+++ b/community/rest/APKBUILD
@@ -2,20 +2,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rest
pkgver=0.8.1
-pkgrel=0
-pkgdesc="A library for access to RESTful web services"
+pkgrel=1
+pkgdesc="Library for access to RESTful web services"
url="http://www.gnome.org"
arch="all"
license="LGPL-2.0-or-later"
-depends_dev="libsoup-dev gobject-introspection-dev"
-makedepends="$depends_dev"
+makedepends="automake autoconf libtool
+ libsoup-dev gobject-introspection-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://download.gnome.org/sources/rest/${pkgver%.*}/rest-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/rest/${pkgver%.*}/rest-$pkgver.tar.xz
+ remove-failing-oauth-tests.patch
+ "
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,13 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="824a341db3827e4360abe03e33735918c68913c70d797699ef74271080a1985872006ec70fd994dc8fa3fbfef417e6fe979883c11286512d0ce623b8368e40c3 rest-0.8.1.tar.xz"
+sha512sums="824a341db3827e4360abe03e33735918c68913c70d797699ef74271080a1985872006ec70fd994dc8fa3fbfef417e6fe979883c11286512d0ce623b8368e40c3 rest-0.8.1.tar.xz
+f5a59c259095a68feb1fd54dfb830b48a9b219e8bbf02349c5ff47128ba9f212ac1543659141661b12f705a178e037969e10bf2e0709ffc01f2f217a3ffc3815 remove-failing-oauth-tests.patch"