aboutsummaryrefslogtreecommitdiffstats
path: root/community/riot-web
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2017-12-14 11:31:37 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-12-14 11:31:43 +0000
commita7de03d0308496ecd4cb9ae6883037b50e22870b (patch)
tree04e0edbcd7100fbed115658acc7ccc156a108d96 /community/riot-web
parent874099681d63ca7a0511205a3d34861ba034bfd1 (diff)
downloadaports-a7de03d0308496ecd4cb9ae6883037b50e22870b.tar.bz2
aports-a7de03d0308496ecd4cb9ae6883037b50e22870b.tar.xz
community/riot-web: new aport
Diffstat (limited to 'community/riot-web')
-rw-r--r--community/riot-web/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/riot-web/APKBUILD b/community/riot-web/APKBUILD
new file mode 100644
index 0000000000..691103ba80
--- /dev/null
+++ b/community/riot-web/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=riot-web
+pkgver=0.13.3
+pkgrel=0
+pkgdesc="A glossy Matrix collaboration client for the web"
+url="http://riot.im/"
+arch="noarch"
+options="!check"
+license="Apache-2.0"
+source="https://github.com/vector-im/riot-web/releases/download/v$pkgver/riot-v$pkgver.tar.gz"
+builddir="$srcdir/riot-v$pkgver"
+
+build() {
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/webapps \
+ "$pkgdir"/etc/riot-web
+ cp -r "$builddir" "$pkgdir"/usr/share/webapps/riot-web
+ mv "$pkgdir"/usr/share/webapps/riot-web/config.sample.json \
+ "$pkgdir"/etc/riot-web
+ ln -sf /etc/riot-web/config.json \
+ "$pkgdir"/usr/share/webapps/riot-web/config.json
+}
+
+sha512sums="0768abd23022885cb95de832f1eb923282cf6e49821781b0414133612057b86fe3b0b721321ee6e13e98c816d4ec4a6d69c623ea639f41fb20a81f911a712798 riot-v0.13.3.tar.gz"