aboutsummaryrefslogtreecommitdiffstats
path: root/community/ripmime
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-20 22:10:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 09:09:35 +0000
commit25a7f6b6ec0c8e4bca178ef14a3f4f7462e9f569 (patch)
tree787a09f2ba9d23246191d43965ab17435313b8a6 /community/ripmime
parent5c436ade0c1759346ee6aecd4cbf60bde231586c (diff)
downloadaports-25a7f6b6ec0c8e4bca178ef14a3f4f7462e9f569.tar.bz2
aports-25a7f6b6ec0c8e4bca178ef14a3f4f7462e9f569.tar.xz
community/ripmime: fix build with gcc8 (useful -Werror)
Note the package builds its tnef/tnef.c assuming the platform is big-endian, e.g. on x86_64, line 22: http://build.alpinelinux.org/buildlogs/build-3-8-x86_64/community/ripmime/ripmime-1.4.0.10-r0.log This seems very wrong but this patch does not try to fix it.
Diffstat (limited to 'community/ripmime')
-rw-r--r--community/ripmime/APKBUILD6
-rw-r--r--community/ripmime/ripmime-1.4.0.10-gcc8.patch33
2 files changed, 37 insertions, 2 deletions
diff --git a/community/ripmime/APKBUILD b/community/ripmime/APKBUILD
index 856d82bb88..d480b41255 100644
--- a/community/ripmime/APKBUILD
+++ b/community/ripmime/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=ripmime
pkgver=1.4.0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to extract the attached files out of a MIME package"
url="https://pldaniels.com/ripmime/"
arch="all"
@@ -13,6 +13,7 @@ install=""
subpackages="$pkgname-doc"
source="https://pldaniels.com/ripmime/ripmime-$pkgver.tar.gz
ripmime-1.4.0.10-makefile.patch
+ ripmime-1.4.0.10-gcc8.patch
"
builddir="$srcdir/ripmime-$pkgver"
@@ -32,4 +33,5 @@ package() {
}
sha512sums="e1eae0ad93a50e19ab1966a6f95ae8704e59bc081f89da1e2894a3bb2a2eaea8b0fc4709ec29d126053517d56c72d6ee2a77f0d8e3fb5f223255d45e0b515ab0 ripmime-1.4.0.10.tar.gz
-a400e446a8de8ffa3c167155a601a5291b795e9875f51910c34b2f037cf5bf4cefb7e344bc3099878a36aa009d97e84c170dc6a5180721b4a82b7a1484a9c11d ripmime-1.4.0.10-makefile.patch"
+a400e446a8de8ffa3c167155a601a5291b795e9875f51910c34b2f037cf5bf4cefb7e344bc3099878a36aa009d97e84c170dc6a5180721b4a82b7a1484a9c11d ripmime-1.4.0.10-makefile.patch
+3a07e8b6716c06e264cc25a15aeac0a6449322e55b037b37e44bcca2e7fa59adc2eb6925374529a7bef91f128b5b67480f60463e5a96b1f5e5ad9f6da4f2a43c ripmime-1.4.0.10-gcc8.patch"
diff --git a/community/ripmime/ripmime-1.4.0.10-gcc8.patch b/community/ripmime/ripmime-1.4.0.10-gcc8.patch
new file mode 100644
index 0000000000..40e51f8924
--- /dev/null
+++ b/community/ripmime/ripmime-1.4.0.10-gcc8.patch
@@ -0,0 +1,33 @@
+--- a/MIME_headers.c
++++ b/MIME_headers.c
+@@ -2957,7 +2957,7 @@
+
+ // Initialise header defects array.
+ hinfo->header_defect_count = 0;
+- memset(hinfo->defects, 0, _MIMEH_DEFECT_ARRAY_SIZE);
++ memset(hinfo->defects, 0, sizeof(hinfo->defects[0]) * _MIMEH_DEFECT_ARRAY_SIZE);
+
+ snprintf( hinfo->content_type_string, _MIMEH_CONTENT_TYPE_MAX , "text/plain" );
+
+--- a/pldstr.c
++++ b/pldstr.c
+@@ -297,7 +297,7 @@
+
+ result = st->start;
+
+- if ((st->start)&&(st->start != '\0'))
++ if ((st->start)&&(*(st->start) != '\0'))
+ {
+ stop = strpbrk( st->start, delimeters ); /* locate our next delimeter */
+
+--- a/ripOLE/pldstr.c
++++ b/ripOLE/pldstr.c
+@@ -297,7 +297,7 @@
+
+ result = st->start;
+
+- if ((st->start)&&(st->start != '\0'))
++ if ((st->start)&&(*(st->start) != '\0'))
+ {
+ stop = strpbrk( st->start, delimeters ); /* locate our next delimeter */
+