aboutsummaryrefslogtreecommitdiffstats
path: root/community/rippled
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-12-11 18:49:12 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-12-11 21:59:53 +0200
commit05f05a9e4eeef9383df87a8149ad31e615fb5775 (patch)
treeb33605af5cb23ea45243f1722d05ac42dd6ad0ed /community/rippled
parent3a27239b8c13955cad7b33b97a44648591224880 (diff)
downloadaports-05f05a9e4eeef9383df87a8149ad31e615fb5775.tar.bz2
aports-05f05a9e4eeef9383df87a8149ad31e615fb5775.tar.xz
community/rippled: upgrade to 1.1.1
Diffstat (limited to 'community/rippled')
-rw-r--r--community/rippled/APKBUILD16
-rw-r--r--community/rippled/musl-fixes.patch49
2 files changed, 8 insertions, 57 deletions
diff --git a/community/rippled/APKBUILD b/community/rippled/APKBUILD
index 895d605f77..ec784c083f 100644
--- a/community/rippled/APKBUILD
+++ b/community/rippled/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=rippled
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1.1
+pkgrel=0
pkgdesc="Blockchain daemon implementing the Ripple Consensus Ledger"
url="https://ripple.com/"
arch="x86_64"
@@ -10,16 +10,16 @@ license="ISC"
makedepends="cmake openssl-dev boost-dev protobuf-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ripple/$pkgname/archive/$pkgver.tar.gz
+ 8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch::https://github.com/ripple/rippled/commit/8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch
fix-tests.patch
- musl-fixes.patch
"
builddir="$srcdir/"$pkgname-$pkgver
build() {
cd "$builddir"
mkdir build && cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release
- make
+ cmake .. -Dstatic=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release
+ cmake --build .
}
check() {
@@ -35,6 +35,6 @@ package() {
install -D -m644 cfg/validators-example.txt "${pkgdir}/etc/$pkgname/validators.txt"
}
-sha512sums="1ec63bb2615d15e20e5adf28f9598b84c842181a948e9bdb7eb78632a5189f27b7d88539697f7f1b5dea698331928373fc9fc7883751e624bea3ea559a4716bb rippled-1.0.1.tar.gz
-cc038e87adf97e4dcd5ea60ff6f45fc988177358b02c116134b65b08dd69a0079f38b56e0dc11c4faaeadc2d707ba5eeeb1a5869dbe95a0cf616599926566d58 fix-tests.patch
-fb063fa49278a5ffbe3fb3f2c348e83f0b936bc35cab181ef02575f4a3a2ad08997dad970b101b5d9796706757e29cd1d1546da1b550e875be08d01c7e31ef16 musl-fixes.patch"
+sha512sums="d8983d0477aa0b7546499dcab6c783ce6f16b9c7c7027da2af8b502bf371750a363a5b22fe255c39266b9a719530eb6ad8bdfe337213752f6d58737e69bdbd0a rippled-1.1.1.tar.gz
+b1882e45d79a0a375f8bdfa5b2154cf027a7af23778b85796c8d89f08fc64d39ce231630950f646e5a0e88a59c634bd538b042f33141f90ef809cc9d76011a98 8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch
+cc038e87adf97e4dcd5ea60ff6f45fc988177358b02c116134b65b08dd69a0079f38b56e0dc11c4faaeadc2d707ba5eeeb1a5869dbe95a0cf616599926566d58 fix-tests.patch"
diff --git a/community/rippled/musl-fixes.patch b/community/rippled/musl-fixes.patch
deleted file mode 100644
index c7615d7e1d..0000000000
--- a/community/rippled/musl-fixes.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/src/ripple/basics/StringUtilities.h b/src/ripple/basics/StringUtilities.h
-index f4cc83f..d2aa4bd 100644
---- a/src/ripple/basics/StringUtilities.h
-+++ b/src/ripple/basics/StringUtilities.h
-@@ -26,6 +26,7 @@
- #include <boost/format.hpp>
- #include <sstream>
- #include <string>
-+#include <endian.h>
-
- namespace ripple {
-
-diff --git a/src/ripple/basics/base_uint.h b/src/ripple/basics/base_uint.h
-index cfa6867..1ce4ec3 100644
---- a/src/ripple/basics/base_uint.h
-+++ b/src/ripple/basics/base_uint.h
-@@ -31,6 +31,7 @@
- #include <ripple/basics/hardened_hash.h>
- #include <ripple/beast/utility/Zero.h>
- #include <boost/functional/hash.hpp>
-+#include <endian.h>
- #include <functional>
- #include <type_traits>
-
-diff --git a/src/rocksdb2/util/log_buffer.h b/src/rocksdb2/util/log_buffer.h
-index 2a24bf8..ddaaa2c 100644
---- a/src/rocksdb2/util/log_buffer.h
-+++ b/src/rocksdb2/util/log_buffer.h
-@@ -9,6 +9,7 @@
- #include "util/arena.h"
- #include "util/autovector.h"
- #include <ctime>
-+#include <sys/time.h>
-
- namespace rocksdb {
-
-diff --git a/src/ripple/beast/core/core.unity.cpp b/src/ripple/beast/core/core.unity.cpp
-index 83dd1df..b374634 100644
---- a/src/ripple/beast/core/core.unity.cpp
-+++ b/src/ripple/beast/core/core.unity.cpp
-@@ -113,7 +113,7 @@
- #include <net/if.h>
- #include <sys/ioctl.h>
-
-- #if ! BEAST_ANDROID && ! BEAST_BSD
-+ #if ! BEAST_ANDROID && ! BEAST_BSD && 0
- #include <execinfo.h>
- #endif
- #endif