aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-26 21:37:45 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-27 15:30:37 +0200
commit80365694380bab5540e0914748b200f53133ee8b (patch)
tree12fe89339cfb1eca6b8f41eaf0c9469ea9247a6b /community/roundcubemail
parentcc204055d54f7bb963788a20b16fc4db7b5c7184 (diff)
downloadaports-80365694380bab5540e0914748b200f53133ee8b.tar.bz2
aports-80365694380bab5540e0914748b200f53133ee8b.tar.xz
community/roundcubemail: add logrotate config
Diffstat (limited to 'community/roundcubemail')
-rw-r--r--community/roundcubemail/APKBUILD6
-rw-r--r--community/roundcubemail/roundcubemail.logrotate6
2 files changed, 11 insertions, 1 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 0a9e723357..7a53cb8fbc 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -40,6 +40,7 @@ source="https://github.com/roundcube/$pkgname/releases/download/$pkgver/$pkgname
config-session_key.patch
fpm-pool.conf
$pkgname.confd
+ $pkgname.logrotate
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -83,6 +84,8 @@ package() {
done
_mv ./$_destdir/LICENSE ./usr/share/licenses/roundcube/
+ install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
+
install -d -m 750 -o roundcube -g roundcube ./var/log/roundcube
}
@@ -119,4 +122,5 @@ sha512sums="c5e1e80034392ea4fcf780750ad2b7db43422a746462015865cbdb027e9e47b2bae7
d205ba8442870b26f93fb287e7fe2bd1a452ea534823869b7ef299e2dca52d64c8a3fdc9a44bd3bc731c1e400efcf745c1866974e3b908e4e54d05b47b835f3e fix-dirs.patch
7c4b88da4d2baa53d247dcb7b130d564954a04611c13f2770f45924fafab2a0e98f8dd078cabc87f3eddd0ab03f3ca48a48f27a462676354af22566cb19d220b config-session_key.patch
c88d609e94c212215a24f54d2a2cb800d4a382b1044e0c875416bdda6a4e6c0cb896675918e8d24f3ed9e1b677d526d61f3ee1564cb870f674dac687696e8ba4 fpm-pool.conf
-acaa76bfbba6117172a02ad11e39f9b55838895104e75180b057f647156c04fd2e44ac695a333f2332691d19bac5ef8afaca1f89ad409800b19f78afbb40aecb roundcubemail.confd"
+acaa76bfbba6117172a02ad11e39f9b55838895104e75180b057f647156c04fd2e44ac695a333f2332691d19bac5ef8afaca1f89ad409800b19f78afbb40aecb roundcubemail.confd
+2e923d556d46bd7dc9360c3190fa1c5864bd0385fadaf73dacee5780cdad94ce09bc8462ccc05c3ca70bc7890aa1f1b3314a3cc831eab9d5b06c5a463483ccf7 roundcubemail.logrotate"
diff --git a/community/roundcubemail/roundcubemail.logrotate b/community/roundcubemail/roundcubemail.logrotate
new file mode 100644
index 0000000000..649bef0d1f
--- /dev/null
+++ b/community/roundcubemail/roundcubemail.logrotate
@@ -0,0 +1,6 @@
+/var/log/roundcube/*.log {
+ daily
+ rotate 7
+ compress
+ copytruncate
+}