aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-16 10:04:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-16 10:07:11 +0000
commitec8ce1596c00bebee3bd18e2348b8fc663b4b952 (patch)
treebc8d577ec60ab226eee46918fcc89bb767615653 /community/roundcubemail
parentc5697baa8bf55ee6b26b7f92077ba76c43944d1a (diff)
downloadaports-ec8ce1596c00bebee3bd18e2348b8fc663b4b952.tar.bz2
aports-ec8ce1596c00bebee3bd18e2348b8fc663b4b952.tar.xz
community/roundcubemail: upgrade to 1.3.4
Diffstat (limited to 'community/roundcubemail')
-rw-r--r--community/roundcubemail/APKBUILD12
-rw-r--r--community/roundcubemail/fix-dirs.patch22
2 files changed, 17 insertions, 17 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index ce9ce96f5f..9ee60c4ab9 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_php=php7
pkgname=roundcubemail
-pkgver=1.3.3
+pkgver=1.3.4
pkgrel=0
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
@@ -39,7 +39,7 @@ prepare() {
sed -i -e 's|temp/|/tmp/|' \
-e 's|config/|/etc/roundcube/|' \
-e 's|logs/|/var/log/roundcube/|' \
- config/defaults.inc.php || return 1
+ config/defaults.inc.php
# cleanup
sed -i 's/\r//' SQL/mssql.initial.sql
@@ -66,10 +66,10 @@ package() {
for file in CHANGELOG INSTALL README.md UPGRADING
do
mv "$pkgdir"/usr/share/webapps/roundcube/$file \
- "$pkgdir"/usr/share/doc/roundcube || return 1
+ "$pkgdir"/usr/share/doc/roundcube
done
mv "$pkgdir"/usr/share/webapps/roundcube/LICENSE \
- "$pkgdir"/usr/share/licenses/roundcube || return 1
+ "$pkgdir"/usr/share/licenses/roundcube
}
installer() {
@@ -79,5 +79,5 @@ installer() {
"$subpkgdir"/usr/share/webapps/roundcube
}
-sha512sums="7cd1c5198e29a20145d70258e2792599f96383f142f0db7322fc348940e71c46c6961c8506b237463d78e6a1ce5c1bd51787f3659e24de9258270ea26b8133fd roundcubemail-1.3.3.tar.gz
-5c645ab7f130f8f3b17b7821e2cd0be88b6d7999da38876bde36c9b116bf7d34bcf52e2d8939d9359649e3fc5ddfb1cab7798ffb9e649be11bebd1d2c4ee006b fix-dirs.patch"
+sha512sums="bb42f95ea6d506ca2aacd9cb7ebcaa7e7f5eaa0a270eb7f041aefd96d441d1d27e245d997809547af0642180fe58f4607e688a6c5868c8a3add6ae1aa22b8169 roundcubemail-1.3.4.tar.gz
+c067a786dada439829bf9b68a3a15e592b2e889de7d4fd7ea90316fcd3196f0c2bdfee53e9a9c2daa2d5c556fcf8453fa50fc5b01599a41109ff76c2a50a1d90 fix-dirs.patch"
diff --git a/community/roundcubemail/fix-dirs.patch b/community/roundcubemail/fix-dirs.patch
index e4a537700d..ce881fbeac 100644
--- a/community/roundcubemail/fix-dirs.patch
+++ b/community/roundcubemail/fix-dirs.patch
@@ -1,14 +1,3 @@
---- a/installer/index.php
-+++ b/installer/index.php
-@@ -41,7 +41,7 @@
-
- define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
- define('RCUBE_INSTALL_PATH', INSTALL_PATH);
--define('RCUBE_CONFIG_DIR', INSTALL_PATH . 'config/');
-+define('RCUBE_CONFIG_DIR', '/etc/roundcube');
-
- $include_path = INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
- $include_path .= INSTALL_PATH . 'program/include' . PATH_SEPARATOR;
--- a/program/include/iniset.php
+++ b/program/include/iniset.php
@@ -44,7 +44,7 @@
@@ -20,3 +9,14 @@
}
if (!defined('RCUBE_LOCALIZATION_DIR')) {
+--- a/program/lib/Roundcube/bootstrap.php
++++ b/program/lib/Roundcube/bootstrap.php
+@@ -65,7 +65,7 @@
+ }
+
+ if (!defined('RCUBE_CONFIG_DIR')) {
+- define('RCUBE_CONFIG_DIR', RCUBE_INSTALL_PATH . 'config/');
++ define('RCUBE_CONFIG_DIR', '/etc/roundcube');
+ }
+
+ if (!defined('RCUBE_PLUGINS_DIR')) {