aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-concurrent-ruby
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-26 01:52:19 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-26 01:53:03 +0100
commitc546fe1dfc8d808a459742abbed7bdcb0d36937d (patch)
tree9e305d2e8fd55a75abce959858298b69ed878760 /community/ruby-concurrent-ruby
parent88270893fa116c0ba2c21e84cd6446f383027e29 (diff)
downloadaports-c546fe1dfc8d808a459742abbed7bdcb0d36937d.tar.bz2
aports-c546fe1dfc8d808a459742abbed7bdcb0d36937d.tar.xz
community/ruby-concurrent-ruby: move rake compile to check()
This is needed to run tests, `gem install` doesn't use the binary created by `rake compile`. :(
Diffstat (limited to 'community/ruby-concurrent-ruby')
-rw-r--r--community/ruby-concurrent-ruby/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ruby-concurrent-ruby/APKBUILD b/community/ruby-concurrent-ruby/APKBUILD
index b0c561e404..8ef9c993e9 100644
--- a/community/ruby-concurrent-ruby/APKBUILD
+++ b/community/ruby-concurrent-ruby/APKBUILD
@@ -26,7 +26,6 @@ build() {
gem build $_gemname.gemspec
- rake compile
gem build $_gemname-ext.gemspec
RUBYLIB="$(pwd)/lib" gem install --local \
--install-dir dist \
@@ -38,6 +37,8 @@ build() {
check() {
cd "$builddir"
+
+ rake compile
rspec --tag ~unfinished --tag ~buggy --tag ~edge spec
}