aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rugged/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-19 07:44:44 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 10:01:12 +0000
commit5d37adff9215eab91ae814f5dd3ebc6d7eb7ebd1 (patch)
tree80c7d4f5abe5b9d90f87903f4aa242c98d208b85 /community/ruby-rugged/APKBUILD
parent2fa5109b202105bb8ec7b796f7c56bd9511dce4d (diff)
downloadaports-5d37adff9215eab91ae814f5dd3ebc6d7eb7ebd1.tar.bz2
aports-5d37adff9215eab91ae814f5dd3ebc6d7eb7ebd1.tar.xz
community/ruby-rugged: fix checkdepends (git)
Without git installed check() fails with a bunch of errors like this: 1) Error: IndexRepositoryTest#test_read_tree_with_not_a_tree: Errno::ENOENT: No such file or directory - git /home/user/aports/community/ruby-rugged/src/rugged-0.27.4/test/test_helper.rb:56:in ``' /home/user/aports/community/ruby-rugged/src/rugged-0.27.4/test/test_helper.rb:56:in `clone' /home/user/aports/community/ruby-rugged/src/rugged-0.27.4/test/index_test.rb:322:in `setup'
Diffstat (limited to 'community/ruby-rugged/APKBUILD')
-rw-r--r--community/ruby-rugged/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/ruby-rugged/APKBUILD b/community/ruby-rugged/APKBUILD
index 0cf71f3ec2..15a9213ec2 100644
--- a/community/ruby-rugged/APKBUILD
+++ b/community/ruby-rugged/APKBUILD
@@ -3,12 +3,12 @@
pkgname=ruby-rugged
_gemname=rugged
pkgver=0.27.5
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby bindings to libgit2"
url="https://github.com/libgit2/rugged"
arch="all"
license="MIT"
-checkdepends="libgit2-tests ruby-minitest ruby-rake-compiler ruby-rake"
+checkdepends="libgit2-tests ruby-minitest ruby-rake-compiler ruby-rake git"
makedepends="libgit2-dev>=${pkgver%.*} ruby ruby-dev"
source="$_gemname-$pkgver.tar.gz::https://github.com/libgit2/$_gemname/archive/v$pkgver.tar.gz
fix-extconf-version-check.patch