aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby2.1
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-22 14:58:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-22 15:02:33 +0000
commit6cc513143e80a5762cf43a748175bba604453024 (patch)
tree426c6f01eaab93f6ee8b13c472c796e3fb83d85b /community/ruby2.1
parentad8ed6ce4f46f6ab8af86863049588e0476a0237 (diff)
downloadaports-6cc513143e80a5762cf43a748175bba604453024.tar.bz2
aports-6cc513143e80a5762cf43a748175bba604453024.tar.xz
community/ruby2.1: enable on aarch64
add no-omit-frame-pointer to CPPFLAGS
Diffstat (limited to 'community/ruby2.1')
-rw-r--r--community/ruby2.1/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ruby2.1/APKBUILD b/community/ruby2.1/APKBUILD
index 0848b1c86b..412715e0c3 100644
--- a/community/ruby2.1/APKBUILD
+++ b/community/ruby2.1/APKBUILD
@@ -9,7 +9,7 @@ _abiver="$_majorver.0"
pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
-arch="all !aarch64"
+arch="all"
license="Ruby"
depends=""
makedepends="zlib-dev openssl-dev gdbm-dev db-dev readline-dev
@@ -46,6 +46,7 @@ build() {
# In many places aliasing rules are broken; play it safe
# as it's risky with newer compilers to leave it as it is.
export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
+ export CPPFLAGS="$CPPFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
# ruby saves path to install. we want use $PATH
export INSTALL=install