aboutsummaryrefslogtreecommitdiffstats
path: root/community/runc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-05 18:32:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 18:38:45 -0300
commit76ff73346d335f4b22bc7ec01966172596ac8910 (patch)
tree899b13f01e0f7f41e11668901ab7b6f865f05ba6 /community/runc
parent268b69b781cc266d5eaafc5b4fd4a2ca9d54c2d9 (diff)
downloadaports-76ff73346d335f4b22bc7ec01966172596ac8910.tar.bz2
aports-76ff73346d335f4b22bc7ec01966172596ac8910.tar.xz
community/runc: modernize, fix secfixes
Diffstat (limited to 'community/runc')
-rw-r--r--community/runc/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/community/runc/APKBUILD b/community/runc/APKBUILD
index e9116fa25b..19a06b819a 100644
--- a/community/runc/APKBUILD
+++ b/community/runc/APKBUILD
@@ -11,7 +11,7 @@ pkgrel=0
_ver=v${pkgver/_rc/-rc}
# if we're building against an explicit commit beyond pkgver, use this instead:
-#_ver=${_commit}
+#_ver=$_commit
arch="all"
license="Apache-2.0"
@@ -22,11 +22,11 @@ builddir="$srcdir/src/github.com/opencontainers/runc"
options="!check"
# secfixes:
-# 1.0.0_rc10:
+# 1.0.0_rc10-r0:
# - CVE-2019-19921
-# 1.0.0_rc9:
+# 1.0.0_rc9-r0:
# - CVE-2019-16884
-# 1.0.0_rc7:
+# 1.0.0_rc7-r0:
# - CVE-2019-5736
build() {
@@ -40,7 +40,6 @@ build() {
}
package() {
- cd "$builddir"
install -Dsm755 "$builddir"/runc "$pkgdir"/usr/bin/runc
install -d "$pkgdir"/usr/share/man/man8/
install -Dm644 "$builddir"/man/man8/* "$pkgdir"/usr/share/man/man8/