aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-11 00:07:39 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-17 16:08:01 +0100
commitfd9f6936f183aa71137f26e0499df9e13d003543 (patch)
tree5552fa8d3490a9deb4b7ea9ab0377ea3ca2894ed /community/rust
parent4cc3762b3ab7ace0e9c0ab4530ad4772811d73d8 (diff)
downloadaports-fd9f6936f183aa71137f26e0499df9e13d003543.tar.bz2
aports-fd9f6936f183aa71137f26e0499df9e13d003543.tar.xz
community/rust: build with locked-deps and option-checking
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index bf4d63ee68..b3424810d0 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -77,10 +77,12 @@ build() {
--local-rust-root="/usr" \
--llvm-root="/usr/lib/llvm$_llvmver" \
--musl-root="/usr" \
- --enable-vendor \
+ --disable-docs \
--enable-llvm-link-shared \
- --disable-jemalloc \
- --disable-docs
+ --enable-option-checking \
+ --enable-locked-deps \
+ --enable-vendor \
+ --disable-jemalloc
RUST_BACKTRACE=1 \
RUSTC_CRT_STATIC="false" \