aboutsummaryrefslogtreecommitdiffstats
path: root/community/samurai
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-07-10 08:50:09 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-10 14:43:36 -0300
commit78178f773aa8c5d25536fd27c7c79e50fa351df6 (patch)
tree6eed415d1cb2292bab4e66cb470078f7dd35c582 /community/samurai
parentcc3bf8e425d6a75093512a7c3bbd5beeaabde813 (diff)
downloadaports-78178f773aa8c5d25536fd27c7c79e50fa351df6.tar.bz2
aports-78178f773aa8c5d25536fd27c7c79e50fa351df6.tar.xz
testing/samurai: update to 0.7, move to community
Diffstat (limited to 'community/samurai')
-rw-r--r--community/samurai/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/samurai/APKBUILD b/community/samurai/APKBUILD
new file mode 100644
index 0000000000..358ec4a533
--- /dev/null
+++ b/community/samurai/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=samurai
+pkgver=0.7
+pkgrel=0
+pkgdesc="ninja-compatible build tool written in C"
+url="https://github.com/michaelforney/samurai"
+arch="all"
+license="Apache-2.0"
+options="!check" # No test suite.
+subpackages="$pkgname-doc"
+source="https://github.com/michaelforney/samurai/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="c47120a2b516c0d130c5a01d99972979c69103d1c6b110722c4c6fcac3147df25d60d9d19913d7c78902c257800d6a5e1bcbb775618058ebfe6db29098dc4001 samurai-0.7.tar.gz"