aboutsummaryrefslogtreecommitdiffstats
path: root/community/scapy
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:39:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:39:18 +0000
commit53a4f790089c6699afc42a41e31ea685f1699b18 (patch)
treeed14ac80f5c185eb4de54fb27f86d60921135f5c /community/scapy
parentaa5fc423790c5777efdd436115790e33fa7d5475 (diff)
downloadaports-53a4f790089c6699afc42a41e31ea685f1699b18.tar.bz2
aports-53a4f790089c6699afc42a41e31ea685f1699b18.tar.xz
community/scapy: moved from testing, cleaned up APKBUILD
Diffstat (limited to 'community/scapy')
-rw-r--r--community/scapy/APKBUILD30
-rw-r--r--community/scapy/scapy.post-install9
2 files changed, 39 insertions, 0 deletions
diff --git a/community/scapy/APKBUILD b/community/scapy/APKBUILD
new file mode 100644
index 0000000000..c09d4373eb
--- /dev/null
+++ b/community/scapy/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Paul Kilar <pkilar@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=scapy
+pkgver="2.3.2"
+pkgrel=1
+pkgdesc="Powerful interactive packet manipulation"
+url="http://www.secdev.org/projects/scapy/"
+arch="noarch"
+license="GPL3+"
+depends="python"
+makedepends="python2-dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.zip::https://github.com/secdev/$pkgname/archive/v$pkgver.zip"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="06c1be0b261d36907c3ff24fa443b4aa scapy-2.3.2.zip"
+sha256sums="3de539ca67dd39e41287f0b36afd85188bd437604092726684c98debd816df01 scapy-2.3.2.zip"
+sha512sums="e120800f498a37a435e175725a071facca65c69c006e64d305ac26d70db206ca0b44e11d4e0ba593c6e31fc33452b0494fe8f8c431d9e3a841c38957144c270b scapy-2.3.2.zip"
diff --git a/community/scapy/scapy.post-install b/community/scapy/scapy.post-install
new file mode 100644
index 0000000000..9f2247aabe
--- /dev/null
+++ b/community/scapy/scapy.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+echo "*" >&2
+echo "* If you want to use scapy to his full potential, please do:" >&2
+echo "* apk add py-crypto py-gnuplot pyx tcpdump sox graphviz graphviz ebtables" >&2
+echo "*" >&2
+
+exit 0
+