aboutsummaryrefslogtreecommitdiffstats
path: root/community/seahorse
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:24:53 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:47 +0200
commitffb488e5473089489966e8f9414e16eb7d69ab81 (patch)
treee4dfe203bb5564d5560054346ef629606a89b72e /community/seahorse
parent797b37fd069db1f2c5498acbeffec9bc1da69081 (diff)
downloadaports-ffb488e5473089489966e8f9414e16eb7d69ab81.tar.bz2
aports-ffb488e5473089489966e8f9414e16eb7d69ab81.tar.xz
community/seahorse: move from testing
Diffstat (limited to 'community/seahorse')
-rw-r--r--community/seahorse/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/seahorse/APKBUILD b/community/seahorse/APKBUILD
new file mode 100644
index 0000000000..aa1c2e6c3e
--- /dev/null
+++ b/community/seahorse/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=seahorse
+pkgver=3.32.2
+pkgrel=0
+pkgdesc="GNOME application for managing PGP keys."
+url="https://projects.gnome.org/seahorse/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="openssh dconf"
+makedepends="vala libxml2-utils
+yelp-tools intltool itstool gpgme-dev libsoup-dev
+libsm-dev libsecret-dev gobject-introspection
+gtk+3.0-dev gcr-dev glib-dev meson ninja
+cmake libpwquality-dev openldap-dev avahi-dev"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ meson --prefix=/usr builddir
+ ninja -C builddir
+}
+
+check() {
+ cd "$builddir"
+ meson test -C builddir
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" meson install -C builddir
+}
+
+sha512sums="e372f79907fbc5d60a41ea0db3a91575b0b304c1727c6091f94eec28445cd836faa32754582c59fd1eb8ce784986e63b4c8cabbd46d5e4cacec1150d9ca08481 seahorse-3.32.2.tar.xz"