aboutsummaryrefslogtreecommitdiffstats
path: root/community/sent
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 11:52:19 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 12:30:37 +0100
commita6b747a20227e1dcc98d07a1a0192e783cff6dbb (patch)
tree8b727df3106db252761f534fe5004b43dc2c8289 /community/sent
parentddfb5ecb814169cc8c458ae32b5e5625a8cb57e4 (diff)
downloadaports-a6b747a20227e1dcc98d07a1a0192e783cff6dbb.tar.bz2
aports-a6b747a20227e1dcc98d07a1a0192e783cff6dbb.tar.xz
community/sent: move from testing
Diffstat (limited to 'community/sent')
-rw-r--r--community/sent/APKBUILD38
-rw-r--r--community/sent/config-mk.patch13
2 files changed, 51 insertions, 0 deletions
diff --git a/community/sent/APKBUILD b/community/sent/APKBUILD
new file mode 100644
index 0000000000..9be245b7a9
--- /dev/null
+++ b/community/sent/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=sent
+pkgver=1
+pkgrel=1
+pkgdesc="Simple plaintext presentation tool"
+url="http://tools.suckless.org/sent/"
+arch="all"
+license="MIT"
+depends="farbfeld"
+depends_dev=""
+makedepends="libx11-dev libxft-dev"
+install=""
+subpackages="$pkgname-doc"
+options="!check" # upstream doesn't have a test suite
+source="http://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz
+ config-mk.patch"
+builddir="$srcdir"
+patch_args="-p0"
+
+build() {
+ make -C "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" \
+ install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 example transparent_test.ff nyan.png \
+ "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/
+}
+
+sha512sums="4797468bf949de507662253eac1ec80f566553051f407a55a88ccdd6544532c0d8d0f51bb11b88bdff78e6630519558049569ac0c9d3d8279f243882653ef1c0 sent-1.tar.gz
+f14481b84c0d125216aba3af45b3fe0a559996f8f3c6acdfb3289ee9c601a09267e94efc3a2c7146d4e8514a68ed2461ddbf907a49d857539c121090797bd7e0 config-mk.patch"
diff --git a/community/sent/config-mk.patch b/community/sent/config-mk.patch
new file mode 100644
index 0000000000..dfb5934c40
--- /dev/null
+++ b/community/sent/config-mk.patch
@@ -0,0 +1,13 @@
+--- config.mk.orig 2017-09-19 11:39:26.939320274 +0200
++++ config.mk 2017-09-19 11:39:32.689379959 +0200
+@@ -21,8 +21,8 @@ LIBS = -L/usr/lib -lc -lm -L${X11LIB} -l
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" -D_XOPEN_SOURCE=600
+-CFLAGS += -g -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
+-LDFLAGS += -g ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+ #CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+ #LDFLAGS += ${LIBS}
+