aboutsummaryrefslogtreecommitdiffstats
path: root/community/sg3_utils
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 09:11:08 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-28 14:57:43 +0000
commit3c43d541c43c1fe6a42954350f92c498a7dc5c9d (patch)
treea1e10aa4fd1bcf9c93b83da4ef233d999122a3e8 /community/sg3_utils
parent2424f3cb454b8cd36455cd5e97edf260ff655031 (diff)
downloadaports-3c43d541c43c1fe6a42954350f92c498a7dc5c9d.tar.bz2
aports-3c43d541c43c1fe6a42954350f92c498a7dc5c9d.tar.xz
community/sg3_utils: move from main
Diffstat (limited to 'community/sg3_utils')
-rw-r--r--community/sg3_utils/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/sg3_utils/APKBUILD b/community/sg3_utils/APKBUILD
new file mode 100644
index 0000000000..a399463343
--- /dev/null
+++ b/community/sg3_utils/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sg3_utils
+pkgver=1.42
+pkgrel=1
+pkgdesc="Generic SCSI utilities"
+url="http://sg.danny.cz/sg/sg3_utils.html"
+arch="all"
+options="!check" # No test suite.
+license="BSD-3-Clause, GPL-2.0+"
+depends=
+makedepends="linux-headers"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://sg.danny.cz/sg/p/$pkgname-$pkgver.tgz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d16b65e36b2bccb4fc4c189f97e71fa38e6619f37d668a4ddd74a52c715fa62325288d9737812ed19c80547059dbd27be5a20565e27e1aabb571e8f5f8ac53ad sg3_utils-1.42.tgz"