aboutsummaryrefslogtreecommitdiffstats
path: root/community/shards
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-04-11 17:15:03 +0200
committerMilan P. Stanić <mps@arvanta.net>2020-04-11 17:18:07 +0200
commitc0ff3206db55e2f4aca40418b322e22c3b4ce71d (patch)
tree7433f2bdf4877bc2acd0fa14c6657793132c5be5 /community/shards
parent7d50b28c4f6b34cfeab701f175adb3dd4e725ba6 (diff)
downloadaports-c0ff3206db55e2f4aca40418b322e22c3b4ce71d.tar.bz2
aports-c0ff3206db55e2f4aca40418b322e22c3b4ce71d.tar.xz
community/shards: upgrade to 0.10.0
add crystal-molinillo build dependency because it is needed for this shards version
Diffstat (limited to 'community/shards')
-rw-r--r--community/shards/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/shards/APKBUILD b/community/shards/APKBUILD
index fdc22ae018..d1622e570d 100644
--- a/community/shards/APKBUILD
+++ b/community/shards/APKBUILD
@@ -2,9 +2,10 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=shards
-pkgver=0.9.0
-pkgrel=1
-_minitestver=0.4.2
+pkgver=0.10.0
+pkgrel=0
+_minitestver=0.5.0
+_molinillover=0.1.0
pkgdesc="Dependency manager for the Crystal language"
url="https://github.com/crystal-lang/shards"
arch="x86_64" # limited by crystal aport
@@ -15,6 +16,7 @@ makedepends="yaml-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archive/v$pkgver.tar.gz
minitest.cr-$_minitestver.tar.gz::https://github.com/ysbaddaden/minitest.cr/archive/v$_minitestver.tar.gz
+ molinillo-$_molinillover.tar.gz::https://github.com/crystal-lang/crystal-molinillo/archive/v$_molinillover.tar.gz
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -26,6 +28,7 @@ prepare() {
mkdir -p lib
ln -s ../../minitest.cr-$_minitestver lib/minitest
+ ln -s ../../crystal-molinillo-$_molinillover lib/molinillo
}
build() {
@@ -44,5 +47,6 @@ package() {
make install DESTDIR="$pkgdir" PREFIX=/usr
}
-sha512sums="a06579f1a96cea1fb1ba97c17ae4529439fb7c54572e74b4969921b1a987a1e1be9c9eb8569db94fd4cb4adc098b3085abfd2a6f7015da7f39611a1774d30022 shards-0.9.0.tar.gz
-04eeedbefe017ab41b802514313c62a4673bfffc9f4877b18083d0978666ec2d24cc86dc90db75b2d55d277266a3aac29f237f61e4bab5c4626783a1d54b136a minitest.cr-0.4.2.tar.gz"
+sha512sums="8d41a2553fd99bd44a3e8a9aacbd17f2a1e9f8730f90c4682091e8d2a4f2388818bdfc4e4bf654c3cbebd617a74474fb63f1fb86a62998cf79409d4778649757 shards-0.10.0.tar.gz
+ecd0661340f4d5fa61a730c0ad4e9b8463fe5df32a54c979f28dfe663ed2e40ff19b212e18bb81c89275039474f8ec1072b3c2c5fdf5396973f8a9f641b653cb minitest.cr-0.5.0.tar.gz
+8d74d95896cd7ff510c87e2ffba6ae5f04ceeddde574930ee609851312b65d713a315cc24f9aa3fab02f9447ccb25ef2dd2e8179640b8c5cfb3d7d6b52d1ded5 molinillo-0.1.0.tar.gz"