aboutsummaryrefslogtreecommitdiffstats
path: root/community/shunit2
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2020-02-12 17:29:04 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-12 15:44:51 -0300
commit56404de845115fb5370146fbcccb75f97fe43fd5 (patch)
treeed8bd79e596e198a206a01753225790d6875a294 /community/shunit2
parentad7238081911b4fa702b48ba8e00adce227c8905 (diff)
downloadaports-56404de845115fb5370146fbcccb75f97fe43fd5.tar.bz2
aports-56404de845115fb5370146fbcccb75f97fe43fd5.tar.xz
testing/shunit2: Promote to community
Not having seen (m)any problems with shunit2, we should promote it now maybe. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'community/shunit2')
-rw-r--r--community/shunit2/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/shunit2/APKBUILD b/community/shunit2/APKBUILD
new file mode 100644
index 0000000000..74eab1ddf8
--- /dev/null
+++ b/community/shunit2/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Olliver Schinagl <oliver@schinagl.nl>
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname="shunit2"
+pkgver="2.1.7"
+pkgrel=1
+pkgdesc="A xUnit based unit test framework for Bourne based shell scripts."
+url="https://github.com/kward/shunit2/"
+arch="noarch"
+license="Apache-2.0"
+makedepends="bash dash loksh zsh"
+subpackages="${pkgname}-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/kward/shunit2/archive/v${pkgver}.tar.gz"
+
+check() {
+ _tmpdir="$(mktemp -d -p "${TMPDIR:-/tmp/}" shunit2.XXXXXXXX)"
+ TMPDIR="${_tmpdir}" ./gen_test_report.sh
+ rm -rf "${_tmpdir}"
+}
+
+package() {
+ install -D -m 755 -t "${pkgdir}/usr/bin/" \
+ "shunit2"
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}/" \
+ "README.md"
+}
+
+sha512sums="35453cf2c469eb1bab2fff0624b8037a09d405c377fec0938875a6339749d5934fe246eec5691a121290ae9e4ee5cbf7768b740c5f0010a5345c4e111c50fbbd shunit2-2.1.7.tar.gz"