aboutsummaryrefslogtreecommitdiffstats
path: root/community/snapcast
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-03-24 22:39:37 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-03-25 16:04:18 +0100
commit5efe8a7411f3304ed6ada3432e04c60e69b33890 (patch)
tree666905eab7af86e8a2a3caf4a28cb39031cfef47 /community/snapcast
parent8513c8bb51d563a7ca22c956df520ca59d060a8b (diff)
downloadaports-5efe8a7411f3304ed6ada3432e04c60e69b33890.tar.bz2
aports-5efe8a7411f3304ed6ada3432e04c60e69b33890.tar.xz
community/snapcast: use supervise-daemon
Diffstat (limited to 'community/snapcast')
-rw-r--r--community/snapcast/APKBUILD6
-rw-r--r--community/snapcast/snapcast-client.initd11
-rw-r--r--community/snapcast/snapcast-server.initd7
3 files changed, 10 insertions, 14 deletions
diff --git a/community/snapcast/APKBUILD b/community/snapcast/APKBUILD
index 84a5cdac82..d070018bae 100644
--- a/community/snapcast/APKBUILD
+++ b/community/snapcast/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=snapcast
pkgver=0.19.0
-pkgrel=0
+pkgrel=1
pkgdesc="Synchronous multi-room audio player"
url="https://github.com/badaix/snapcast"
arch="all"
@@ -74,7 +74,7 @@ server() {
}
sha512sums="0ea838e565b39a0e34de05fb96a591232990dabcd00b5f24ac86f8e8bb916bedcd3486d2ced6a4f7a83d0ea7926aacb604684743bb2d12838e9442878698076c snapcast-0.19.0.tar.gz
-833ce6a5fecb023f32df340df98b5cfbecc765735d7133228dd703a6a0c7f2b67ac95aa787ac7119a2eb87e768e5c4deb12738d0b0354db3510d9047f9e9b24f snapcast-client.initd
+bc2219f00fa70890be0c12f6fb8da0ac86949f65c1714648d20f6e83a80e075b8482bafd65ebadcc65708f0c488f9655ad2ddd803e5a061973de4132134acbc0 snapcast-client.initd
fa353d7974d3a8b3b22ff009b762c7c4ee318f9f83e22762a9ebf550484b9fc3cc4dffd389b6d756630dc035cb86d5c5643541957785f8bbf71fe4915691c337 snapcast-client.confd
-ff610e08274d317e0df9590de47f3425d23a38528f82b9998de04d73cf2167ddb6aad237ddce9864b6c36fff959afb6a892c554ce40fd3e3d62c1308b022b2bb snapcast-server.initd
+47feaf72d96ccab6996d24619b1d36a89a74e50d402fb6760792ee62d5c2460718324ef8f437ce2be121488f164372c2c0883b9ff0e45d484b5b0e3778d6d99b snapcast-server.initd
48d494143d044a413b414b32cd8be51d4242234b6d7cb03102914a42b1ea6b1913c2c31b223c23c6be316918e731875149a2505daa03165659d0a1be3ca7e75c snapcast-server.confd"
diff --git a/community/snapcast/snapcast-client.initd b/community/snapcast/snapcast-client.initd
index 9218a5faef..9d5e9cc45d 100644
--- a/community/snapcast/snapcast-client.initd
+++ b/community/snapcast/snapcast-client.initd
@@ -1,18 +1,13 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
+
name=snapclient
command="/usr/bin/snapclient"
-command_args="-d $snapclient_opts"
+command_args="$snapclient_opts"
command_user="snapcast"
-pidfile="/run/snapclient/pid"
depend() {
need net
after firewall
}
-
-start_pre() {
- checkpath --directory --owner snapcast:audio --mode 0775 \
- /run/snapclient
-}
-
diff --git a/community/snapcast/snapcast-server.initd b/community/snapcast/snapcast-server.initd
index 2e6d9a9b67..11b0c2b953 100644
--- a/community/snapcast/snapcast-server.initd
+++ b/community/snapcast/snapcast-server.initd
@@ -1,11 +1,12 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
+
name=snapserver
command="/usr/bin/snapserver"
-command_args="-d $snapserver_opts"
+command_args="$snapserver_opts"
command_user="snapcast"
start_stop_daemon_args="--quiet"
-pidfile="/run/snapserver/pid"
depend() {
need net
@@ -14,6 +15,6 @@ depend() {
start_pre() {
checkpath --directory --owner snapcast:audio --mode 0775 \
- /run/snapserver /var/lib/snapserver
+ /var/lib/snapserver
}