aboutsummaryrefslogtreecommitdiffstats
path: root/community/sndio
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-07-24 12:09:34 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-07-24 12:09:34 +0200
commitea9c891cb1cc300618bb2a8ecf404d1a1a2e1b3b (patch)
treeade687acabf47b46d36457152eb0120d36f35380 /community/sndio
parent4156bf1f8e24ad9620a19dd537cd4e55d668164a (diff)
downloadaports-ea9c891cb1cc300618bb2a8ecf404d1a1a2e1b3b.tar.bz2
aports-ea9c891cb1cc300618bb2a8ecf404d1a1a2e1b3b.tar.xz
community/sndio: move from testing
Diffstat (limited to 'community/sndio')
-rw-r--r--community/sndio/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/sndio/APKBUILD b/community/sndio/APKBUILD
new file mode 100644
index 0000000000..c9add40579
--- /dev/null
+++ b/community/sndio/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sndio
+pkgver=1.6.0
+pkgrel=0
+pkgdesc="Small audio and MIDI framework part of the OpenBSD project"
+url="http://www.sndio.org/"
+arch="all"
+license="ISC"
+depends=""
+makedepends="alsa-lib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://www.sndio.org/sndio-$pkgver.tar.gz"
+builddir="$srcdir/sndio-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="32d668b5d50096cc2c5c29823c066475ceb06e394163d346697ceae853650cb407a77279c30f0fe703df894f19e8c818c1b8c0b84c17480cd54b25b6fc9fe3ce sndio-1.6.0.tar.gz"