aboutsummaryrefslogtreecommitdiffstats
path: root/community/softhsm
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-06 07:56:34 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-23 21:34:18 +0000
commita06ffff95a8af09252e8acb149121c0707b2d54e (patch)
tree56e35a3bd34241b9508ba7cabc921f07045e384c /community/softhsm
parentdca992785e1534c3bd8e0971aed453c42f954e53 (diff)
downloadaports-a06ffff95a8af09252e8acb149121c0707b2d54e.tar.bz2
aports-a06ffff95a8af09252e8acb149121c0707b2d54e.tar.xz
community/softhsm: move from testing
Diffstat (limited to 'community/softhsm')
-rw-r--r--community/softhsm/APKBUILD49
-rw-r--r--community/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch19
2 files changed, 68 insertions, 0 deletions
diff --git a/community/softhsm/APKBUILD b/community/softhsm/APKBUILD
new file mode 100644
index 0000000000..d26426fad8
--- /dev/null
+++ b/community/softhsm/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Frank Felhoffer <silveraid@hackme.ca>
+# Maintainer: tcely <softhsm+aports@tcely.33mail.com>
+pkgname=softhsm
+pkgver=2.5.0
+pkgrel=0
+pkgdesc="cryptographic store accessible through a PKCS #11"
+url="https://www.opendnssec.org/softhsm/"
+arch="all"
+license="BSD-2-Clause"
+depends="sqlite"
+checkdepends="cppunit-dev"
+makedepends="autoconf automake botan-dev libtool p11-kit-dev sqlite-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://dist.opendnssec.org/source/$pkgname-$pkgver.tar.gz
+ softhsm-2.5.0-botan_ecb-exception-fix.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-crypto-backend=botan \
+ --with-botan=/usr \
+ --with-sqlite3=/usr \
+ --with-objectstore-backend-db
+
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir/" install
+}
+
+sha256sums="92aa56cf45e25892326e98b851c44de9cac8559e208720e579bf8e2cd1c132b2 softhsm-2.5.0.tar.gz
+ea369cc09a63955a346967041fea7e79438cc6a4f064c7a93a9bdc1b263c6af2 softhsm-2.5.0-botan_ecb-exception-fix.patch"
+sha512sums="a1e686729196dc25591eb3da57c2c8ea8494ed274ba711842b2dcae696f477a202acda13a975b8fb1eb68e8e44a79e839dbbc6ba500cab02ad13072c660752d9 softhsm-2.5.0.tar.gz
+25dc68c404f89936df1d7fcdf5460b8f42fff66f4a76d0e50f139337cb515fac853aa76b0b276cdb9186f2cd78a4099fcfa469629c1531dfa4023fa19c23823b softhsm-2.5.0-botan_ecb-exception-fix.patch"
diff --git a/community/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch b/community/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch
new file mode 100644
index 0000000000..a71081e0ee
--- /dev/null
+++ b/community/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch
@@ -0,0 +1,19 @@
+commit a9a40fc64635cfb924279cae3c42e6946e89718c
+Author: tcely <tcely@users.noreply.github.com>
+Date: Wed Mar 6 07:14:32 2019 -0500
+
+ fix protected Exception usage
+
+diff --git a/src/lib/crypto/Botan_ecb.cpp b/src/lib/crypto/Botan_ecb.cpp
+index f27276e..6947aab 100644
+--- a/src/lib/crypto/Botan_ecb.cpp
++++ b/src/lib/crypto/Botan_ecb.cpp
+@@ -108,7 +108,7 @@ void ECB_Encryption::finish(secure_vector<byte>& buffer, size_t offset)
+ padding().add_padding(buffer, bytes_in_final_block, BS);
+
+ if(buffer.size() % BS)
+- throw Exception("Did not pad to full block size in " + name());
++ throw Invalid_State("Did not pad to full block size in " + name());
+
+ update(buffer, offset);
+ }