aboutsummaryrefslogtreecommitdiffstats
path: root/community/soundtouch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-05 18:31:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 18:38:44 -0300
commit11fff6132f01db63cd200aa0c79259672787b202 (patch)
tree6c7b0717fb4b5f89a0e7dc6557abcb0f90082ad2 /community/soundtouch
parentd17a014c3419283d71293e0cd45a8c7178393632 (diff)
downloadaports-11fff6132f01db63cd200aa0c79259672787b202.tar.bz2
aports-11fff6132f01db63cd200aa0c79259672787b202.tar.xz
community/soundtouch: modernize
Diffstat (limited to 'community/soundtouch')
-rw-r--r--community/soundtouch/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
index 7ac42124e2..fda6a88804 100644
--- a/community/soundtouch/APKBUILD
+++ b/community/soundtouch/APKBUILD
@@ -6,28 +6,22 @@ pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
url="http://www.surina.net/soundtouch/"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev autoconf automake libtool"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="https://gitlab.com/soundtouch/soundtouch/-/archive/$pkgver/soundtouch-$pkgver.tar.bz2"
-builddir="$srcdir"/soundtouch-$pkgver
# secfixes:
# 2.1.2-r0:
-# - CVE-2018-17096
-# - CVE-2018-17097
-# - CVE-2018-17098
+# - CVE-2018-17096
+# - CVE-2018-17097
+# - CVE-2018-17098
prepare() {
default_prepare
- cd "$builddir"
./bootstrap
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,7 +36,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/doc
}