aboutsummaryrefslogtreecommitdiffstats
path: root/community/soundtouch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-25 13:51:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-25 13:51:31 +0000
commit730eb4aa5de35d1fdc909515b8e41c047d921af6 (patch)
treec679c70ecc62b45e1cd17ee9d463f2ba17eca8a0 /community/soundtouch
parentd25f6e1109beb363084b6622d646241177984b0d (diff)
downloadaports-730eb4aa5de35d1fdc909515b8e41c047d921af6.tar.bz2
aports-730eb4aa5de35d1fdc909515b8e41c047d921af6.tar.xz
community/soundtouch: move from main
only needed by audacity
Diffstat (limited to 'community/soundtouch')
-rw-r--r--community/soundtouch/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
new file mode 100644
index 0000000000..7e41760fb6
--- /dev/null
+++ b/community/soundtouch/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=soundtouch
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
+url="http://www.surina.net/soundtouch/"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/soundtouch
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ ./bootstrap
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/doc
+}
+
+md5sums="2d1ab4abb54640e8e308e36e309c94a6 soundtouch-1.9.2.tar.gz"
+sha256sums="caeb86511e81420eeb454cb5db53f56d96b8451d37d89af6e55b12eb4da1c513 soundtouch-1.9.2.tar.gz"
+sha512sums="d8f3f8970198a46ef3dc252719749bc19cbd2f8de5e00eeb2874565bfc421b60d94d400bacf702591293e595edf6c1c35917b6153fd395cad8d6b03115da7068 soundtouch-1.9.2.tar.gz"