aboutsummaryrefslogtreecommitdiffstats
path: root/community/soundtouch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 23:29:45 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 23:31:35 +0200
commit73233acb7aefbd6ded31ae04498b10e2dbd373b8 (patch)
tree6e52e353164100760eee5a6d96d1849b5d7e644b /community/soundtouch
parent6759bf356df6b7a16747ee342baf97b1e18d9425 (diff)
downloadaports-73233acb7aefbd6ded31ae04498b10e2dbd373b8.tar.bz2
aports-73233acb7aefbd6ded31ae04498b10e2dbd373b8.tar.xz
community/soundtouch: fix build, modernize APKBUILD
Diffstat (limited to 'community/soundtouch')
-rw-r--r--community/soundtouch/APKBUILD30
1 files changed, 10 insertions, 20 deletions
diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
index 7e41760fb6..4cf21396e8 100644
--- a/community/soundtouch/APKBUILD
+++ b/community/soundtouch/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=soundtouch
pkgver=1.9.2
-pkgrel=0
+pkgrel=1
pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
url="http://www.surina.net/soundtouch/"
arch="all"
@@ -11,24 +11,17 @@ depends_dev=""
makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
- "
+source="http://www.surina.net/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/soundtouch
-_builddir="$srcdir"/soundtouch
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
+ cd "$builddir"
./bootstrap
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,17 +31,14 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-shared \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/doc
}
-md5sums="2d1ab4abb54640e8e308e36e309c94a6 soundtouch-1.9.2.tar.gz"
-sha256sums="caeb86511e81420eeb454cb5db53f56d96b8451d37d89af6e55b12eb4da1c513 soundtouch-1.9.2.tar.gz"
sha512sums="d8f3f8970198a46ef3dc252719749bc19cbd2f8de5e00eeb2874565bfc421b60d94d400bacf702591293e595edf6c1c35917b6153fd395cad8d6b03115da7068 soundtouch-1.9.2.tar.gz"