aboutsummaryrefslogtreecommitdiffstats
path: root/community/spice-gtk
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 18:04:09 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 18:28:15 +0000
commit1c46f5706baf3b5531ab1b3ce43280fa48d84a14 (patch)
treef72983921608d7388ca7bb07d389ba517ab545bf /community/spice-gtk
parentcc3c64a9242ce0b328011caa0c4f9caac0d4e010 (diff)
downloadaports-1c46f5706baf3b5531ab1b3ce43280fa48d84a14.tar.bz2
aports-1c46f5706baf3b5531ab1b3ce43280fa48d84a14.tar.xz
community/spice-gtk: modernize
Diffstat (limited to 'community/spice-gtk')
-rw-r--r--community/spice-gtk/APKBUILD15
-rw-r--r--community/spice-gtk/libressl.patch39
2 files changed, 4 insertions, 50 deletions
diff --git a/community/spice-gtk/APKBUILD b/community/spice-gtk/APKBUILD
index 22a80e6a4c..b4a0431488 100644
--- a/community/spice-gtk/APKBUILD
+++ b/community/spice-gtk/APKBUILD
@@ -2,29 +2,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
pkgver=0.35
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK+ widget for SPICE clients"
url="http://spice-space.org/page/Spice-Gtk"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
depends_dev="gtk+3.0-dev polkit-dev libxrandr-dev openssl-dev
cyrus-sasl-dev gst-plugins-base-dev libjpeg-turbo-dev zlib-dev
acl-dev lz4-dev opus-dev"
makedepends="$depends_dev bash usbutils python2-dev eudev-dev phodav-dev
usbredir-dev libusb-dev libsoup-dev spice-protocol
- polkit-dev py-parsing gobject-introspection-dev
+ py-parsing gobject-introspection-dev
"
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib"
-source="https://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2
- libressl.patch
- "
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,7 +39,6 @@ build() {
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
@@ -64,5 +58,4 @@ glib() {
"$subpkgdir"/usr/lib/girepository-1.0/
}
-sha512sums="f0914a4a9baf892e39dab7d51aa9f5ab4dbb4ef01f09da158b20756f890745837d0a6c8c1f7897844e695be2ed01f3b1d04ada1cacc958b5cfadb0d4bf7c4729 spice-gtk-0.35.tar.bz2
-f5e029e59bb64f073aea2fb2416e54d460981b365807f161795810a56a6268d4da681e3d64d17c2e8ed5bc49f736bbc88b933bedbf790b19ca91e599a8829f7e libressl.patch"
+sha512sums="f0914a4a9baf892e39dab7d51aa9f5ab4dbb4ef01f09da158b20756f890745837d0a6c8c1f7897844e695be2ed01f3b1d04ada1cacc958b5cfadb0d4bf7c4729 spice-gtk-0.35.tar.bz2"
diff --git a/community/spice-gtk/libressl.patch b/community/spice-gtk/libressl.patch
deleted file mode 100644
index 4c362b0ae1..0000000000
--- a/community/spice-gtk/libressl.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/spice-common/common/ssl_verify.c b/spice-common/common/ssl_verify.c
-index 27aa5d3..a9ed650 100644
---- a/spice-common/common/ssl_verify.c
-+++ b/spice-common/common/ssl_verify.c
-@@ -33,7 +33,7 @@
- #include <string.h>
- #include <gio/gio.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined (LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000
- static const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1)
- {
- return M_ASN1_STRING_data(asn1);
-diff --git a/src/bio-gio.c b/src/bio-gio.c
-index 30aa73b..6b1ef9a 100644
---- a/src/bio-gio.c
-+++ b/src/bio-gio.c
-@@ -23,7 +23,7 @@
- #include "spice-util.h"
- #include "bio-gio.h"
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000
- static BIO_METHOD one_static_bio;
-
- static int BIO_meth_set_read(BIO_METHOD *biom,
-diff --git a/src/spice-channel.c b/src/spice-channel.c
-index 6f3ca27..55344a3 100644
---- a/src/spice-channel.c
-+++ b/src/spice-channel.c
-@@ -55,7 +55,7 @@ static void spice_channel_reset_capabilities(SpiceChannel *channel);
- static void spice_channel_send_migration_handshake(SpiceChannel *channel);
- static gboolean channel_connect(SpiceChannel *channel, gboolean tls);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000
- static RSA *EVP_PKEY_get0_RSA(EVP_PKEY *pkey)
- {
- if (pkey->type != EVP_PKEY_RSA) {