aboutsummaryrefslogtreecommitdiffstats
path: root/community/spring-boot-openrc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-31 14:12:03 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-31 14:12:03 +0200
commit8e4268331928843212c778422cc826198b4732f6 (patch)
treef7086ed861761c97b2b81cadb67834f04369be91 /community/spring-boot-openrc
parent8dd748b5bbc57fd4f1a80f910145beba729862ac (diff)
downloadaports-8e4268331928843212c778422cc826198b4732f6.tar.bz2
aports-8e4268331928843212c778422cc826198b4732f6.tar.xz
community/spring-boot-openrc: moved from testing
Diffstat (limited to 'community/spring-boot-openrc')
-rw-r--r--community/spring-boot-openrc/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/spring-boot-openrc/APKBUILD b/community/spring-boot-openrc/APKBUILD
new file mode 100644
index 0000000000..e85bf22cc3
--- /dev/null
+++ b/community/spring-boot-openrc/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=spring-boot-openrc
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="OpenRC runscript for Java applications based on Spring Boot"
+url="https://github.com/jirutka/spring-boot-openrc"
+arch="noarch"
+license="MIT"
+depends="socat"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ./install
+}
+
+md5sums="680d5e96ddfeb1d7c42ce80aec04c0aa spring-boot-openrc-0.1.1.tar.gz"
+sha256sums="8299e27811a63ae97c83cfe10e3341edf2537c0661b1bfa83db76b3fd684a463 spring-boot-openrc-0.1.1.tar.gz"
+sha512sums="5879fa75816a8d176463d06e1186a773294296664580909e3bcb52256b7dccfd0c0cc7e71060ae23f76e2cc84845d196e4fa56d4488292fd5b0e0925a7e85d1d spring-boot-openrc-0.1.1.tar.gz"