aboutsummaryrefslogtreecommitdiffstats
path: root/community/startup-notification/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 21:06:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:32:57 -0300
commit001b9d73f25238237dc6f5a3349cc3c77d5243fb (patch)
tree2212240885a3eb49dbe09194d609e64b46d5acb6 /community/startup-notification/APKBUILD
parent85eecb9ab964135dde1c97b75391acd3869fdf4a (diff)
downloadaports-001b9d73f25238237dc6f5a3349cc3c77d5243fb.tar.bz2
aports-001b9d73f25238237dc6f5a3349cc3c77d5243fb.tar.xz
community/startup-notification: move from main
Diffstat (limited to 'community/startup-notification/APKBUILD')
-rw-r--r--community/startup-notification/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/startup-notification/APKBUILD b/community/startup-notification/APKBUILD
new file mode 100644
index 0000000000..54645173d4
--- /dev/null
+++ b/community/startup-notification/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=startup-notification
+pkgver=0.12
+pkgrel=3
+pkgdesc="Monitor and display application startup"
+url="http://www.freedesktop.org"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-dev"
+depends=
+makedepends="libx11-dev libsm-dev xcb-util-dev"
+source="https://www.freedesktop.org/software/$pkgname/releases/$pkgname-$pkgver.tar.gz"
+
+depends_dev="libsm-dev xcb-util-dev"
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="ea1246acdb50dafd9ced9914ec3c8f0d499c0ca3cfd447b43a444c768a6e9ea7135e5c42d9ca0089354698ac235bd86d42f12c70a3a17c9c79f998c07461f7ab startup-notification-0.12.tar.gz"